Close Back
Nickname:

This field is mandatory.

Your nickname is incorrect.

Your nickname is too short.

Username already exists.

Your nickname is too long.

E-mail:

This field is mandatory.

Your email is invalid.

Email already exists.

Password:

This field is mandatory.

Your password is too short.

Your password is too long.

Password equals nickname.

Repeat the password:

This field is mandatory.

Repeated password is incorrect.

I accept the terms of service & privacy policy

This field is mandatory.

I hereby consent to process my personal data for marketing purposes including receiving commercial information in electronic format.

Congratulations

Your account has been created!
In order to activate it, please click on the link found in the confirmation email we've sent you.


User Tag List

Results 1 to 1 of 1
  1. #1
    Zmutowane Dziecko Kalen123's Avatar
    Join Date
    05/2010
    Location
    Kraków
    Posts
    156
    REDpoints
    348
    Achievements
    18

    Obiekt kolizyjny (eksport z 3ds Maxa)

    Witam.
    Mam problem z eksporterem obiektów 3D do REDkit'a. Niby wszystko jest dobrze, ale niestety obiekt kolizyjny, który stworzyłem w 3ds Maxie nie przypomina kształtem tego w edytorze (ten w edytorze jest jakby matematycznym uproszczeniem tego z Maxa). Raczej nie jest to wina wielkości, ponieważ mój obiekt kolizyjny ma ok. 15 polygonów, więc nie w tym problem. Próbowałem też stworzyć kilka osobnych obiektów połączonych w jedno, ale efekt jest taki sam jak poprzednio.
    Dziękuję za wszelką pomoc.

    #EDIT

    Witam ponownie. Ciągle borykam się z tym problem, więc edytuję post.
    Postaram się w skrócie opisać czynności jakie robię przed eksportem (może gdzieś popełniam błąd).
    Na początku tworzę obiekt. Dodaję do niego dwa obiekty typu _LOD1 i _LOD2 (uproszczone wersje mojego modelu, stosowane dla lepszej płynności gry)
    Następnie tworzę bardzo uproszczony model kolizyjny
    Click image for larger version. 

Name:	4.JPG 
Views:	22 
Size:	53.7 KB 
ID:	66

    Nazywam go 'moj_obiekt_COLL' (końcówkę _COLL stosuję zgodnie z zaleceniem eksportera)
    Zaznaczam wszystkie 4 modele i eksportuję je. Po imporcie do silnika REDkit wszystkie obiekty (_LOD0, _LOD1, _LOD2) wyglądają dobrze, ale obiekt _COLL wygląda tak, jak na obrazku poniżej. Jest on matematycznym uproszczeniem mojego obiektu kolizyjnego.
    Click image for larger version. 

Name:	2.JPG 
Views:	18 
Size:	91.5 KB 
ID:	67

    Natomiast dziwne rzeczy dzieją się, gdy zamiast nazwy 'moj_obiekt_COLL' wpiszę '_COLL'. Po kolejnym eksporcie obiekt w silniku przypomina ten poprawny (chodzi o ułożenie werteksów w przestrzeni), ale ściany są całkowicie źle. Widać to na rysunku poniżej:
    Click image for larger version. 

Name:	1.jpg 
Views:	15 
Size:	73.0 KB 
ID:	68

    Próbowałem już wszystkich możliwych sztuczek np.
    - Ręczne definiowanie ID materiału na obiekcie;
    - Linkowanie do obiektu;
    - Rozkład siatki UV obiektu;
    - Ręczną edycję w samym REDkit (jest tam kilka funkcji, żadna nie działa);
    - Nakładanie różnych tekstur na obiekt (wiele tekstur na jeden obiekt);
    - Tworzenie wielu obiektów kolizyjnych;
    Żadna nie działa...:mad:


    Przez trzy ostatnie miesiące stworzyłem wiele obiektów 3D przeznaczonych głównie na potrzeby mojego moda (ok. 12 domów ze wsi, dość duże miasto i jeden średniej wielkości zamek). Na obrazku poniżej przykładowy screen miasta:
    Click image for larger version. 

Name:	5.jpg 
Views:	22 
Size:	93.9 KB 
ID:	69



    Dlatego proszę o jakąś pomoc, ponieważ byłaby wielka szkoda gdybym nie mógł użyć tych obiektów w mojej przygodzie.
    Last edited by Kalen123; 18-05-2013 at 04:45 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •