x

You have decided to merge your account with the GOG.com.

You can now start participating in the community discussions.

x

You chose to opt out from the merge process.
Please note that you will not be able to access your account until you opt in.

We strongly encourage you to merge your RED account with the GOG.com one.
If you want to do it later please try logging in again.

  • Register

Announcement

Collapse
No announcement yet.

Audio sync issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    -- IF ANYONE IS STILL HAVING THIS ISSUE THIS FIX WILL MOST LIKELY WORK FOR YOU. I WAS HAVING THIS ISSUE AND IT FIXED IT --

    Basically, windows uses an internal clock that assists with timing events such as syncing audio and video. If it is out of whack for whatever reason, this desync in lips and voices can happen.

    You can disable this clock and change it to your platform clock by opening command prompt as an administrator (search "cmd" on the windows start menu, right click cmd and click "run as administrator") and then pasting in this line:

    bcdedit /set useplatformclock true

    Then just restart your PC.

    This is 100% safe and if for whatever reason you need to change it back to the windows clock, just change "true" to "false".

    Hope this helps someone.

    Comment


    • #17
      Immensely helpful advice incon. My audio sync could never decide if it wanted to go too fast or too slow but your fix worked perfectly. Thanks for speaking up.

      Comment


      • #18
        I simply lowered the resolution and it fixed itself. In the highest available resolution, it would unsync, even in low video settings. Dropped resolution down a nod and play it in medium / high video settings without problem.

        Comment


        • #19
          Welcome to the Forums, incon45!

          Originally posted by incon45 View Post
          -- IF ANYONE IS STILL HAVING THIS ISSUE THIS FIX WILL MOST LIKELY WORK FOR YOU. I WAS HAVING THIS ISSUE AND IT FIXED IT --

          Basically, windows uses an internal clock that assists with timing events such as syncing audio and video. If it is out of whack for whatever reason, this desync in lips and voices can happen.

          You can disable this clock and change it to your platform clock by opening command prompt as an administrator (search "cmd" on the windows start menu, right click cmd and click "run as administrator") and then pasting in this line:

          bcdedit /set useplatformclock true

          Then just restart your PC.

          This is 100% safe and if for whatever reason you need to change it back to the windows clock, just change "true" to "false".

          Hope this helps someone.
          Curious... I wonder why this would be the case. The system clock should be far more accurate than the Windows clock. It'll be interesting to see if this affects a large number of people. I'm also interested to see if it affects some of the languages experiencing audio speed-up during certain dialogue scenes. Nice catch, though!
          People always ask me, "What's in the box?" I get the question a lot. "Come on -- what's in the box!?" I won't tell them...but I'll tell you. Go on.
          You can see what's IN THE BOX!!!

          Comment

          Working...
          X