x

You have decided to merge your account with the GOG.com.

You can now start participating in the community discussions.

x

You chose to opt out from the merge process.
Please note that you will not be able to access your account until you opt in.

We strongly encourage you to merge your RED account with the GOG.com one.
If you want to do it later please try logging in again.

  • Register

Announcement

Collapse
No announcement yet.

Witcher 3 and NVMe drives

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SOLVED Witcher 3 and NVMe drives

    I'm beginning to think this game is incompatible with NVMe drives due to the way the game streams data, which seems to be more optimized for SATA drives. I recently bought a Samsung 960 Pro 1TB, and although the game loads faster than ever, I'm noticing micro stutter in congested areas like Novigrad which do not appear when using my SATA based 850 Pro. I know that NVMe loads data in larger chunks than SATA, which somehow seems to conflict with the way the game streams data because when Geralt is running through Novigrad, I'm noticing micro stutter. I've tried everything to get rid of it, like changing drives, settings, doing a verify/repair install etcetera and nothing has changed.

    I also made sure that my NVMe is using PCIe 3.0 4x like it's supposed to, and that my motherboard is updated to the latest UEFI. System is a 6900K Intel, Asus X99A II, 32GB DDR4 3400, Titan Xp and Samsung 960 Pro 1TB.

    Out of all the games I have installed on my system, this is the only one which exhibits this behavior, so that is why I think it's just the game itself.

  • #2
    Out of all games you own, this is the only one that uses the RED Engine 3, so it makes perfect sense that this is the only one to give you this issue. The problem occurs on HDD or SSD. I've battled with the hitching and stuttering since the game was released (and I've won every battle, dang it!)

    From my experience, the key is frame-timing. Presently, on an i7-4790K, GTX 980 ti, 16 GB RAM, and a Samsung EVO SSD, I must use the following to avoid the stutter:

    Nvidia Control Panel:

    Anisotropic Filtering = 16x (nice tweak with no performance cost)
    Pre-rendered frames = 1
    Vsync = Controlled by the 3D application
    Monitor Refresh Rate = 60 Hz

    In-Game:
    Fullscreen, 1080p
    Vsync = On
    Frame Limit = 48 (manually edit user.settings and change FPSLimit=XX)

    At 60 FPS, the game did not "stutter", per say, but I was getting pretty wild swings from a smooth 60 all the way down to the 30's, seemingly at random. At 48 FPS, the performance is rock-solid. The engine itself needs to sync a lot of stuff, so leaving plenty of performance overhead is a great idea. Using any form of unlimited FPS or adaptive Vsync / Half Refresh / G-Sync options seem to introduce the stutter and/or other issues. The sweet-spot will be different for different systems, but the key is to ensure the FPS ceiling is lowered to a point that the CPU / GPU are able to run hand-in-hand. If the GPU gets far enough ahead of what the engine / CPU is doing, you are rewarded with stutter or hitching.

    Also, disable any and all overclocking while running the game. TW3 does not seem to like it very much.
    People always ask me, "What's in the box?" I get the question a lot. "Come on -- what's in the box!?" I won't tell them...but I'll tell you. Go on.
    You can see what's IN THE BOX!!!

    Comment


    • #3
      @ SigilFey, thanks for the input man. It took awhile for me to respond because I actually uninstalled the game because I was so pissed off. Later on though, I wondered if the stuttering might have been due to the Logitech gaming software that I had installed. That gave me some issues with Gears of War 4 funnily enough. But I just installed Witcher 3 again tonight, and the same issue keeps occurring.

      I'm completely convinced it's the game itself. There's no other explanation, because when I play the game from my Samsung 850 pro (on the exact same computer, with the same settings), it plays very smooth. On my 960 pro on the other hand, it's a stuttering mess, especially in Novigrad. I think the algorithms that control resource loading and caching for the game just seem to be incompatible with the NVMe protocol, which wants to load bigger chunks of information compared to SATA. I've always said the Red Engine 3 is a crap engine. It's more of a crossgen engine in terms of its behavior, despite the fact that the Witcher 3 is a current gen only game.

      I can only hope that Red Engine 4 or whatever Cyberpunk 2077 will use doesn't have this problem, because NVMe is only going to continue to proliferate.

      Comment


      • #4
        Originally posted by prince_of_nothing View Post
        I'm completely convinced it's the game itself. There's no other explanation, because when I play the game from my Samsung 850 pro (on the exact same computer, with the same settings), it plays very smooth. On my 960 pro on the other hand, it's a stuttering mess, especially in Novigrad.
        I know it can be frustrating to work through these things, but it's not the game itself. If it were, everyone would be seeing exactly the same situation on all platforms and all system configs. I run the game flawlessly on my 980 ti. Learning to manage your unique system is the key, and it can be really hard to track down stubborn issues. The biggest challenge is understanding that not all systems perform the same way -- even if one contains "better" hardware. (Adding more power can often make things worse.)

        NVMe drives are still very new tech. It's possible that you'll need to keep up with the firmware until the issue is resolved. If that's even what's causing it... Basically, what you're identifying here is a neverending cycle that has been around for as long as I've been gaming (starting in the early 80's on a state-of-the-art Commodore 64 ). New hardware hits the market; none of my games work properly anymore. I could come up with examples of this for hours on end. It's not possible for developers to see the future and produce software that will run well on hardware that isn't even established yet. (Anyone who games on PC will eventually experience this over and over again.)

        For TW3 in particular, the game is not meant to run at high FPS. Many gamers don't understand this or simply don't like it (and both are completely understandable). The game is ideally trying to run at 30 FPS. The engine is incredible...but not for "blazing performance". It's meant to create open, organic environments filled with scripted activities, massive and versatile NPC populations, sweeping environmental vistas, lush terrain and vegetation, seamless internal and external transitions, intricate cinematics, and enormous player character customizability. But, yeah...to accomplish this the framerate can chug along in places.

        I would still recommend NOT trying to get a solid 60 if getting stutters. Try to lower your performance so that things fall in sync. I've not used an NVMe drive myself, so I'm afraid I can't provide any tips in that regard. I can only reinforce that this sounds like the classic frame-timing issues that have been posted about since the game was released, and may have nothing to do with the NVMe.

        People always ask me, "What's in the box?" I get the question a lot. "Come on -- what's in the box!?" I won't tell them...but I'll tell you. Go on.
        You can see what's IN THE BOX!!!

        Comment


        • #5
          The issue has been solved. The source of the problem was Windows itself, specifically the Creators spring update! After clean installing Windows 10 Fall update, the issue has been completely fixed, and Witcher 3 plays buttery smooth on my 960 Pro the way it should have from the get go!


          Microsoft admitted that in certain games and applications, the Creators Spring update could cause stuttering and lag, though they never specified what caused this to occur.

          Well whatever it was, it has been completely and totally fixed with the Creators Fall update. So if your games are stuttering and you can't figure out what the cause is, try updating or clean installing to the latest Windows 10 Creators fall update!

          Thanks @ SigilFey for attempting to help me troubleshoot it!

          Comment


          • #6
            Originally posted by prince_of_nothing View Post
            Well whatever it was, it has been completely and totally fixed with the Creators Fall update.
            And that's also a common thing with new versions of an OS. Strange that you seemed to suffer with it for so long -- but glad to see it's rolling now!
            People always ask me, "What's in the box?" I get the question a lot. "Come on -- what's in the box!?" I won't tell them...but I'll tell you. Go on.
            You can see what's IN THE BOX!!!

            Comment

            Working...
            X