Jobs Support Register

Audio sync issues

+

zappnickel

Poser
#1
Audio sync issues

Not sure if I'm the only one but I haven't seen any posts about it here. I'm playing on the PC and the audio and lip sync is off. Graphics card is a bit old but game runs decent otherwise. Not a game breaker but a bit of an immersion breaker. Any ideas what it could be and a fix?
 

herkles

Poser
#3
I am having a similar issue. there is no stutter in the sound like what is going on with Kingerliran's video but the voice and lip syncing is off. Game runs fine for me other wise.
 

zappnickel

Poser
#4
I'm not having a stuttering issue. The sound and game is fine. It's in any dialog, the lips and the audio are not in sync. In a sense... the lips and the movement are lagging or the audio is too fast; depending on which way you look at it.
 

Catoid

Poser
#5
Same issue here - it looks to me as if the animation of the speaking runs too slow. The voices all sound normal (i.e. not sped up), but then the speaking stops and the characters' lips are still moving. My computer did fail the test for this game on www.systemrequirementslab.com, so I figured this was a dicey proposition, but it's actually running fairly smoothly with most of the settings low. I did change the framerate from 60 to 30 and that seemed like it might have helped in the conversation between Geralt and the historian in the pub, but then I went and talked to a couple other characters and it was back to the same sort of delays.
 

kargsure

Poser
#6
I'm also experiencing the audio sync issues listed above - although like Catioid, my laptop is slightly under spec as well though everything else runs fine on lower settings.
 

chetan.N

Poser
#7
me too same, + sound stutters a lot

---------- Updated at 12:57 PM ----------

i tried setting affinity to cpu 1 its solved the problem but video performance downgraded
 

Nexous

Poser
#9
Same with my PC version using nvidia card. PS4 version has no sync problems that i`ve heard
 

Catoid

Poser
#10
I do have the hairworks turned off, and most of my quality settings are at Low or Medium, but it does still happen at least some of the time. If this is just a consequence of my computer not meeting the minimum specs, I'm content to live with it. I'm just wondering if there's some specific setting I can or should change that would help (aside from disabling hairworks, which like I said I've already done).
 

annaray

Poser
#11
video is at least a second behind audio at worst, gradually worsens

My sync problem is severe but mostly 50% of the time. Guess the video is at least a second behind the audio. But sometimes ( new start it is gone and gradually comes back.
PC is AMD quad 4.2 gig. CPU ; HD 6970 crossfire; 12 gig memory. It is the only game I have this problem( DA Inquisition, Witcher 2 and and so on, no problems) use Bit defender Anti virus in game mode, Windows 8.1 and nothing else. Is windows 8.1 installation only for games.
Hope fast for a patch to solve the problem
 

theso33ul

Poser
#12
Any fix for this yet? I'm having problems with this, but only Geralt's lips are out of sync. Other characters have no problem.
 

ktron

Poser
#13
I had this problem and I found a strange fix. I was researching this and another post suggested running fraps (fps viewer) to get an idea of the frame rate, so I downloaded and ran, Witcher wouldn't run with fraps in the background for some reason. So I ran Witcher then Ctrl+Alt+Del out of the game then run fraps then go back into the game - important make sure your in the game not title screen. Amazingly the game ran like 100% better and no sync issues!!! Would be interested if this works for others?? BTW I have GTX970 with i7 3770K.
 

ktron

Poser
#15
So basically run Witcher 3 then fraps and go back in the game? Do I need to do that every time I play?
Yes unfortunately. But it only takes 10 seconds and the game pauses when you Ctl+Alt+Del anyway, as I said earlier make sure your in game not on the title screen . I have the game default at 60 fps and fraps confirms that speed - you can then press F11 to remove the speed indicator in the top LH corner. Try saving just before a conversation and after doing above try the conversation again, I will be intrigued to know if it works for others.
 

incon45

Junior Member
#16
-- IF ANYONE IS STILL HAVING THIS ISSUE THIS FIX WILL MOST LIKELY WORK FOR YOU. I WAS HAVING THIS ISSUE AND IT FIXED IT --

Basically, windows uses an internal clock that assists with timing events such as syncing audio and video. If it is out of whack for whatever reason, this desync in lips and voices can happen.

You can disable this clock and change it to your platform clock by opening command prompt as an administrator (search "cmd" on the windows start menu, right click cmd and click "run as administrator") and then pasting in this line:

bcdedit /set useplatformclock true

Then just restart your PC.

This is 100% safe and if for whatever reason you need to change it back to the windows clock, just change "true" to "false".

Hope this helps someone.
 

granolaman137

Junior Member
#17
Immensely helpful advice incon. My audio sync could never decide if it wanted to go too fast or too slow but your fix worked perfectly. Thanks for speaking up.
 

sochoco

Junior Member
#18
I simply lowered the resolution and it fixed itself. In the highest available resolution, it would unsync, even in low video settings. Dropped resolution down a nod and play it in medium / high video settings without problem.
 

SigilFey

Moderator
#19
Welcome to the Forums, incon45!

incon45;n7473230 said:
-- IF ANYONE IS STILL HAVING THIS ISSUE THIS FIX WILL MOST LIKELY WORK FOR YOU. I WAS HAVING THIS ISSUE AND IT FIXED IT --

Basically, windows uses an internal clock that assists with timing events such as syncing audio and video. If it is out of whack for whatever reason, this desync in lips and voices can happen.

You can disable this clock and change it to your platform clock by opening command prompt as an administrator (search "cmd" on the windows start menu, right click cmd and click "run as administrator") and then pasting in this line:

bcdedit /set useplatformclock true

Then just restart your PC.

This is 100% safe and if for whatever reason you need to change it back to the windows clock, just change "true" to "false".

Hope this helps someone.
Curious... I wonder why this would be the case. The system clock should be far more accurate than the Windows clock. It'll be interesting to see if this affects a large number of people. I'm also interested to see if it affects some of the languages experiencing audio speed-up during certain dialogue scenes. Nice catch, though!