Jobs Store Support Register

Cannot Use my Mouse Properly Because the Game Shows the Xbox Keybinding

+
Xbox One pad on Win10 PC problem

Hi. There is a bug with Xbox one controller on my pc. I plugged in my pad to my PC for another game than Gwent, and now Gwent only recognize my controller, even if the pad is not plugged in, and even if I restart my PC without the pad plugged in. It's quite boring. Can CDPR add an option to the game to choose the controller, mouse or pad ? It could be nice.

I really tried every option to bypass that bug, reinstall the game without the pad, restart my computer etc...

Thank you
 
That's strange. I sometimes have a Xbox One pad plugged in on my PC (but only use mouse and keyboard), however, that only causes issues when buttons are pressed and unplugging the controller always solves the issue for me.

But I agree that it would be good to have an option in the menu to manually switch between both control methods.

If the issue remains, please contact CDPR support:
https://www.playgwent.com/en/contact-support
 
For me, even when the pad is unplugged, the game shows me "press A to start the game", and in the menu my mouse cursor is invisible, so the only solution for me is to play with the pad.
I'm on dual screen, maybe it is a part of the problem I don't know.
 
Jeliz thread merged

The problem is likely due to a third party driver interfering with Gwent. Some other things (workaround) you can try:

I found short term solution but it's not a good solution for people who use gamepad in other games. Gwent uses xinput and loading it always when games starts, to resolve our problem just go to C:\Windows\System32 and found xinput1_3.dll and rename it, xinput1_3-old.dll is ok. Now when you start the game it will be unable for exe to load settings for gamepad and game will run in forced mouse and keyboard mode. For me everything works flawless now. If someone of you use gamepad in other games then you need to rename it again to xinput1_3.dll when you finish playing in gwent.
I found a solution for this issue.. The conflict is caused by a software called "vJoy".. I don't know why I had it installed but just uninstall it and PROBLEM SOLVED! (If you don't have that "vJoy" installed try to uninstall any third party program for the controls)

Another way:

- Right Click on My Computer and select 'Manage'
- Select 'Device Manager' from the pane on the left
- Expand 'Human Interface Devices'
- Right click on 'HID-compiant game controller' and select 'Disable'
- Done!
 
Thank you Armed and Devivre, i'll try this as soon as I can. Nonetheless, CDPR should add an option to choose the controller we want, if you can tell them it would be great.
 
Well well well... you may gonna laugh but I've found the "problem". In fact, my Xbox one controller was plugged in, as well as my Thrustmaster Hotas that I use to play Elite. So I unplugged it and no probleme anymore...
I should have try to play Gwent with my hotas, could be fun !

However thank you for the help guys !
 
Hello. I am running Gwent on PC, and I'm having an issue with my mouse cursor disappearing. When the game loads and the CDPR logo comes up, it switches from my regular cursor to the standard Gwent cursor, then disappears just before the public beta message shows up. The prompts are all changed to XBox controller prompts, even when I unplug the controller. The mouse still works (I can select everything just fine), but I can't see the cursor. It briefly reappears when I quit the game.

I would appreciate any help to resolve this problem. Thanks for your time and effort.
 
S_Holmes Post moved to a dedicated thread.

The problem is likely due to a third party driver interfering with Gwent. Some other things (workaround) you can try:

I found short term solution but it's not a good solution for people who use gamepad in other games. Gwent uses xinput and loading it always when games starts, to resolve our problem just go to C:\Windows\System32 and found xinput1_3.dll and rename it, xinput1_3-old.dll is ok. Now when you start the game it will be unable for exe to load settings for gamepad and game will run in forced mouse and keyboard mode. For me everything works flawless now. If someone of you use gamepad in other games then you need to rename it again to xinput1_3.dll when you finish playing in gwent.
I found a solution for this issue.. The conflict is caused by a software called "vJoy".. I don't know why I had it installed but just uninstall it and PROBLEM SOLVED! (If you don't have that "vJoy" installed try to uninstall any third party program for the controls)

Another way:

- Right Click on My Computer and select 'Manage'
- Select 'Device Manager' from the pane on the left
- Expand 'Human Interface Devices'
- Right click on 'HID-compiant game controller' and select 'Disable'
- Done!
Also, perusing this thread might also give you some other suggestions.
 
Still unplayable due to this issue. I usually have 3-4 joysticks plugged into my PC and don't want to unplug they all every time when I want to play Gwint and plug again after game. I just can't believe that it's a big deal to add one option - "use only keyboard and mouse". It's simple, trust me. I apologize if my post looks rude but this issue exist looong time and any patience has a limit.
 
BillyCrusher;n10627181 said:
Still unplayable due to this issue. I usually have 3-4 joysticks plugged into my PC and don't want to unplug they all every time when I want to play Gwint and plug again after game. I just can't believe that it's a big deal to add one option - "use only keyboard and mouse". It's simple, trust me. I apologize if my post looks rude but this issue exist looong time and any patience has a limit.
Unfortuately, it's more how Windows prioritizes available controllers than K+M not being active. The trouble is (especially with very sensitive flight sticks / gamepads), if the PC detects input from one of them, like when joysticks begin to "drift" a bit with age, it can snag focus away from the M+K and/or interfere with input for other controllers. It's a normal problem for a lot of different games. Programming in the ability for a game to recognize an input device (simply to tell it to ignore it) is a load of work that will apply to very few players. Plus, all it takes is a 3rd-party driver installation (like Saitek or Razer stuff), and it would still override the game settings, as those drivers usually function by hooking actual keyboard commands.

I'm afraid that unless you find a sweet-spot with hardware that all "cooperates" with each other, unplugging peripherals is the only way around this.
 
Sorry, but I know (not guess) how it works in games and I know that add checkbox for completely ignoring joysticks input it very easily to do (of course if you want to do it). Yes, there are very few games (usually console ports) which don't care about input separation, for absolute majority it's not an issue. But I've already found solution. For now I play TESL which doesn't have such issue and feel happy.
 
Mouse/keyboard bug with hotas

Is it possible to fix the bug when we have a hotas who disable mouse/keyboard when lauching the game.

Seriously, this bug is in the game since day one alpha and still not fixed.

The only solution given is to unplug device or desactivate joystick through device manager. We are in 2018 and this bug can't be fixed ? It's the only game i've played which have this issue
 
Last edited:
Mouse clicks do not register in menus and in-game

Stopped playing for about two months and just today thought I'd try the game again only to find out that I can no longer use my mouse for some reason.
When I start the game, I can click through the first few screens just fine until the 'continue' button pops up. I can move the mouse cursor to it but when I try clicking on it nothing happens.
What does work is the keyboard but the keyboard controls are so obnoxious to use, it really makes the game pretty much unplayable without also having the mouse there.
In the in game menus it's exactly the same. I can move the mouse cursor as normal but the clicks don't register at all.

I've already tried:

- Running the game as administrator
- Disabling Enhanced cursor pointing
- Switching to full screen
- Restarting / Repairing
- Uninstalling and reinstalling
- Disabling all other input systems

I am not using any kind of external controller, just a regular mouse and keyboard. My mouse works perfectly fine outside of the game and this problem did not occur when I last played the game about two months ago. Clearly something has gone seriously wrong in one of the updates to the game since then.
 
Calrael thread merged

The problem is likely due to a third party driver interfering with Gwent. If, after unplugging all (Xbox) controllers, the problem still persists, please try the workarounds below:

I found short term solution but it's not a good solution for people who use gamepad in other games. Gwent uses xinput and loading it always when games starts, to resolve our problem just go to C:\Windows\System32 and found xinput1_3.dll and rename it, xinput1_3-old.dll is ok. Now when you start the game it will be unable for exe to load settings for gamepad and game will run in forced mouse and keyboard mode. For me everything works flawless now. If someone of you use gamepad in other games then you need to rename it again to xinput1_3.dll when you finish playing in gwent.
I found a solution for this issue.. The conflict is caused by a software called "vJoy".. I don't know why I had it installed but just uninstall it and PROBLEM SOLVED! (If you don't have that "vJoy" installed try to uninstall any third party program for the controls)

Another way:

- Right Click on My Computer and select 'Manage'
- Select 'Device Manager' from the pane on the left
- Expand 'Human Interface Devices'
- Right click on 'HID-compiant game controller' and select 'Disable'
- Done!
Also, perusing this thread might also give you some other suggestions.
 
4RM3D;n10892011 said:
Calrael thread merged

The problem is likely due to a third party driver interfering with Gwent. If, after unplugging all (Xbox) controllers, the problem still persists, please try the workarounds below:
Also, perusing this thread might also give you some other suggestions.
Why was the thread merged exactly? I said specifically that I don't have any third party controllers connected (don't even own an Xbox controller) and already tried disabling all other input devices. Also I had already read through the thread in question by the time I made the thread.
Still tried the workarounds mentioned but unsurprisingly they don't work (I don't even have a 'HID-compliant game controller' listed on the Device manager).
And since the game worked perfectly fine when I played it previously, it seems rather obvious this is a different issue, one that is caused by changes made in a recent patch.
 
Calrael

Because, even without a controller, the third party software can still interfere. Many users unplugged their device, but the problem persisted. It usually comes down to that. However, your case might be an exception. Though, if your mouse only has issues when playing Gwent, my best bet is still that some third party software is interfering. It's difficult to troubleshoot without knowing your entire configuration. I would recommend running a dxdiag with the 64-bit option selected and send the results to CDPR Support along with a brief description of the issue. They are able to provide technical support for more exotic issues.
 
Played the game for month a lot (5 hours a day) and never had a problem. Till today, now my cursor doesnt appear when the game is loaded, the button of "continue" changes weirdly into an "A button" and back when I move my mouse... Clicking the mouse still lets me continue but when I wanna click the menu or other things, all the menus just freak out when I roll over with my cursor (which I dont see).

Anyone else having this problem? So weird the game worked perfectly for months....

Things I tried: Repair option of the client, restarting, restarting PC
 

Attachments