Jobs Support Register

Crashes/Freezes in Shop and in-game

+
Since the last patch, there seems to be a problem with certain (older) AMD cards, which causes various game crashes.

Please, contact CDPR support directly, so that they can collect more information to (hopefully) fix this problem.

UPDATE (thanks to @bloomlight): The fix for the issue is adding a unity argument to the Gwent shortcut: -force-feature-level-10-1

It should look like this:


For other solutions, please try the following:
  1. Update your graphics card drivers.
  2. For performance issues, try to disable V-Sync and Card Animations.
  3. Try a verify / repair through GOG Galaxy and ensure Galaxy itself is up to date.
  4. Install / repair redistributables that come wit the game (DirectX, Visual Studio, etc.).
  5. Be sure the game is not installed under Program Files or Program Files(x86) and set up the .EXE files of Galaxy and Gwent to "Run as administrator".
  6. Disable your virus protection software / firewall.
  7. Close all background applications, especially Chrome (and other resource-consuming apps).
  8. If that doesn't work; try to reinstall the game and manually remove the following folders (back up your Thronebreaker save games before that!):
    1. "C:\Users\<Your username>\AppData\Local\Temp\CDProjektRED"
    2. "C:\Users\<Your username>\AppData\LocalLow\CDProjektRED"
 
Every time I click on "Open Goodies", the game freezes on transition effect and after a while, it crashes to desktop. The only reason I even know about this is that someone mentioned on reddit and I tried it out because I have a similar issue.

The big deal is that my game crashes whenever I right-click on "Deck" in-game.

I tried changing pretty much all of the settings around and the CTD is consistent, no changes. This used to happen pre-patch upon exiting the Shop after opening kegs, although rarely. Now it happens 100% of the time. I'll try the driver reinstall recommended in Support section, but I'm pretty sure it's up-to-date.
 
Absolutely the same problem strictly after the patch... Also Gwent now crashes after the first round when mulligan interface should appear. Nothing helps.
 
If nothing helps it‘s best to contact support (the contact link can be found in the support link I mentioned in my previous post)
 
Yep, nothing helped, tried everything you mentioned and even repeated the process with a non-WHQL driver with no results. I've submitted a support ticket, now all that's left is to wait... And watch other people play Gwent, lol.
 
A few more considerations:

1.) Ensure neither the game nor Galaxy is installed anywhere under Program Files or Program Files(x86). Always install games to the root of the drive or a folder of your own creation. Protected directories can create issues.

2.) Add the game to any anti-virus / firewall / etc. program that you may be using. Especially if you're using a more aggressive form of anti-virus, (Norton, McAffee, etc.) you may need to completely disable it for certain games to run correctly.

(^ From the sound of the crash, I believe it's most likely one of these.)

3.) Install / repair your Microsoft Redistributables. Aside from the ones included in the installation package, also grab:
Direct X 11/12 (whichever you're using)
Direct X 9.0c (June 2010 version should work with Windows 10)
.NET Framework
XNA Framework

For Visual Studio and Visual C++, be sure you're installing both the x86 and x64 versions of each year. So, for example, as I believe Studio and C++ 2013 is particularly important to Gwent, install as follows:
Visual Studio 2013 x86
Visual Studio 2013 x64
Visual C++ 2013 x86
Visual C++ 2013 x64

Let us know if anything there makes a difference!
 
Well, I got an answer from Support today and sent them my logs, so I'll hold off on implementing any changes until they say anything.
 
Welp, they're still working on it. Meanwhile, through some trial and error, I've found out that it's likely due to the new blur effect... In the end, my trash GFX card is probably the main perpetrator.

@SigilFey Tried all of those, nothing's changed... Thanks for trying.
 
Meanwhile, through some trial and error, I've found out that it's likely due to the new blur effect... In the end, my trash GFX card is probably the main perpetrator.
At least they should add an option to disable the blur effect then.
Not uncommon for shaders to cause strange issues like this. Can you be more specific about what you've tested and the results?
 
Sure.
With the exception of first match after game startup, the freeze is triggered by:
  • Mulligan screen - the round 1 mulligan is ok, but hiding it and displaying it again causes the freeze
  • Playing a card which interacts with Deck/Graveyard and requires selection (e.g. Traheaern var Vdyffir, Keira Metz, Ghoul)
  • Right-clicking Graveyard or Deck
Each of those circumstances require the background blur mask, and cause a crash before it comes into play. The accompanying sound effect is played out to the end, though, even if the game is frozen. Also, the first match is only an exception if I didn't wander around other menus (which also have the blur mask) like deck builder.

I haven't tried Shupe yet, IIRC that card also causes the blur when selecting his options, so it should cause the crash as well... I'll try now.
Post automatically merged:

Okay, scratch that. Now every card selection screen causes the crash, no matter whether it's the first game since startup or not. So, cards like Skald and Bran leader ability cause it too.
 
Last edited:
With the exception of first match after game startup, the freeze is triggered by:
  • Mulligan screen - the round 1 mulligan is ok, but hiding it and displaying it again causes the freeze
  • Playing a card which interacts with Deck/Graveyard and requires selection (e.g. Traheaern var Vdyffir, Keira Metz, Ghoul)
  • Right-clicking Graveyard or Deck
Awesomes. If you could send this info into, or follow up with, Support (provided you haven't already done so) this will probably be very helpful. Also be sure to include:

1.) Your GPU make and model
2.) Driver version
3.) Dxdiag using the 64-bit option

Hard to say if the issue is definitely the shaders...but that sounds like a good lead. Either way, being able to test these specifics will likely help! :)
 
Yeah, I've notified them of my observations earlier today. I've also submitted my DxDiag to them. As for Driver version, I told them it's the latest one, the rest should be in DxDiag report.

Welp, hope the solution isn't "get a new GFX card".
 
Yeah, I've notified them of my observations earlier today. I've also submitted my DxDiag to them. As for Driver version, I told them it's the latest one, the rest should be in DxDiag report.

Welp, hope the solution isn't "get a new GFX card".
Mate, can I ask you which graphics card you exactly have? Because I am afraid that GPU is causing our problems. Mine is ATI Radeon HD 6770m. Yeah, it doesn't fit the minimum system requirements, but Radeon R7 240 (declared as minimum GPU) is almost the same card as HD 6770m according to the specifications. HD 6770m is even better in some cases. But may be differences between architectures of those GPU, or the driver to my HD 6770m doesn't get along (it is old and hasn't supported since 2014).

For me getting a new card is not so easy, since 6770m is a laptop graphics card... I'm not sure, that It's a good idea to change my laptop because of Gwent lol.

I have this issue not only in Gwent, but also in Thronebreaker. I haven't done this game yet, since I can't go further the first battle in Angren - the game crashes 100% of time when blur effect at the beggining of the first round comes out. Fortunately, in Gwent there wasn't such a problem in-game (except in Shupe). The game process was just fine! But now, since the patch came out... Dark times for me :(
 
Last edited:
So just like the title says the game has been crashing whenever i try to open kegs (the sound and animation isn't synced most of the time too). I'm quite new to this game and only have 4 hours in it but I tried to open kegs over 20 times and it only opened once. I'm not sure if this is a common thing or not but I was hoping to find a solution for it here. Thanks in advance.
 
If updating the intel & amd drivers doesn‘t work, and your system (including the AMD card) meets the minimum requirements, you can always contact CDPR support (you can find a contact link in the link I mentioned in my other post).
 
I did but it seems that the only way to get the game to not crash is to disable my AMD and force the game to use my intel HD instead. It's still not a solution tho because i don't want to turn the AMD off everytime i play then onafter i'm done.
CDPR broke the game for AMD users with the end of Jan. patch. Nothing helps. The support either keeps silence or answers in a way that they'll look at your issue and logs and then you never hear a word from them again. They even delete posts on Reddit about the no word from support on AMD issue =) Check the tech forums for similar cases.