[FIXED] Infinite loading screen after latest update

Hi guys,

I updated the game to the latest version a week ago and played for a while (I started a NG+ Death March months ago). Everything seemed fine. Since I arrived to Kaer Morhen, whenever I wanted to load a save file I noticed that the game was loading forever. No errors, no crashes, but the loading bar didn't progress, even after 10/30 minutes. I could still load the save file from the main menu once restarted the game. Now I did the primary quests in Kaer Morhen and need to fast travel to Skellige/Novigrad/Velen, etc. and I can't. The game keeps loading and loading, but nothing. I don't even receive any error, so I don't know what the cause could be.

I'm not using any mods. Never used them. The launcher had the "use mod" option already activated. I'm using DirectX 12 as always.

Tried to verify integrity of the game, Steam downloaded two files, but the problem persists. Tried DX11, tried to launch the .exe file of the game, dx 11 and dx 12, tried to disable hairworks, nothing.

I even tried an old save file where I completed the game, DLCs included. Tried to fast travel to Novigrad, it worked, to Skellige worked, to Kaer Morhen worked. But from Kaer Morhen there was the same problem, infinite loading screen, where I guess the game crashes.

I'm not sure that the problem is related to the save files.

PC Specs:

i7 8700k
GTX 1060 6GB
16GB DDR4 3000MHZ

Thanks for the help
Top Bottom