Jobs Support Register

Jak utworzyć world i startup partition?

+

Freire

User
#1
Jak utworzyć world i startup partition?

Hej, próbuję uruchomić grę za pomocą polecenia "Play game" (bez zielonego ptaszka) ale wyskakują mi różne errory. Pierwszy View attachment 206 rozwiązałam tworząc plik "world partition" w AB i dodając go do zakładki World, ale pojawił się drugi: "Startup partition root does not exist in World. Check your resources." View attachment 205 i nie bardzo wiem co mam zrobić. Ma ktoś sugestię?
 

Attachments

KALEN_PL

User
#4
Coś musi być źle z jakimś zadaniem (plik typu quest). Sprawdź czy wszystko masz poprawnie. Ewentualnie spróbuj włączyć grę metodą "na szybko", jeśli będzie działać, to znaczy, że zrobiłaś błąd w pliku 'quest' z filmiku.
 

Freire

User
#5
Zrobiłam jeszcze raz i gra odpala poprawnie, Geralt jest w miejscu gdzie utworzyłam waypoint ALE błędy typu Path Engine View attachment 208 , które prześladują mnie od dłuższego czasu nie znikają, dodatkowo zniknęły mi wszystkie npce :(
 

Attachments

KALEN_PL

User
#6
Jeśli chodzi o błąd typy "Path Engine" to jest on związany z obiektami z którymi Geralt wchodzi w interakcję np. drzwi, drabiny, skały na które można wejść itd.
Raczej nie można go naprawić (jakoś nie widzę funkcji, która byłaby za to odpowiedzialna).
Błąd występuje również w mapach stworzonych przez Redów.
Np. wczytałem mapę Flotsam w edytorze i uruchomiłem ją. Efekt był taki:
View attachment 211

Może kiedyś będzie jakiś "patch", który naprawi ten błąd, ale obecnie nie trzeba się nim zbytnio przejmować:rolleyes:
 

Attachments

Freire

User
#7
nie trzeba się nim zbytnio przejmować:rolleyes:
Tylko że nie widzę przez to dialogów (nie to, że w ogóle jakieś mam, jedynego questa jakiego zrobiłam do tej pory zeżarł mi redkit :p)

Dzięki za pomoc :)
 
Last edited:

Stolarro94

User
#9
Dobra, wiem że tym postem zasłużę na złotą łopatę internetowego archeologa, ale poniżej rozwiązania problemów wyżej wspomnianych.
Path engine error:
Po prostu wyłączamy pokazywanie debugujących wiadomości na ekranie. Klikamy View -> Filters _debug options -> game options -> debug -> wyłączamy ErrorState. (Lub visual debug/onScreenMessages Któryś z tych, nie pamiętam dokładnie. Ale raczej errorstate)
Punkt startowy:
Wybieramy jakąś warstwę. Następnie klikamy ppm gdzieś na mapie -> navigation -> add waypoint. (jeżeli nic się nam nie pokazuje, to wchodzimy ponownie w filtres _debug options a potem w editors options zaznaczamy Sprites). Jak mamy naszego waypointa to wchodzimy w zakładke prosperites. W dziale cNode nadajemu obiektowi jakiś tag. Następnie wchodzimy do zakładki world. Tam nadajemy odpowiedni tag pozycji startowej, czyli utworzonego przed chwilą waypointa.