Jobs Support Register

PC holding down q to cast axii puppet does not work in combat.

+

pvtponcho

Poser
#1
PC holding down q to cast axii puppet does not work in combat.

When out of combat holding down q will cast the puppet axii upgrade, but in combat no matter how long i hold it down it instantly casts the tier 1 axii spell that stuns. Please help!
 

pvtponcho

Poser
#3
Yeah I do. It is so frustrating I don't understand i have a corsair k70 cherry mx red if that's relevant. Like if i'm not fighting anything it will cast when i hold it down most of the time, but it never casts in combat, it just goes for the stun no matter what.
 

fireember160

Poser
#4
I have an almost identical issue. PC (Steam) Version, I cannot cast puppet in combat or out. When I have both delusion and puppet equipped, it won't cast. I can cast puppet if I do not have delusion equipped. I can also only cast puppet when delusion is a maximum of level 1. Once delusion is equipped and giving the bonus of faster axii cast speed, puppet refuses to work in-combat or out.
 

Torcrar

Poser
#6
I have managed to solve this for myself on the PC. It now works! I can have puppet and delusion at the same time.

To fix this:

Navigate to your folder: C:\Users\<User Name>\Documents\The Witcher 3

Open the file "input.settings"

Find all the entries for "IK_Q=(Action=CastSignHold,State=Duration,IdleTime=0.2)"

Change the entry to have an IdleTime of 0.01. So after your change it should look like this:

"IK_Q=(Action=CastSignHold,State=Duration,IdleTime=0.01)"

There are multiple entries of this setting, so you will have to change them all.

I didn't test it with other signs as this is a universal change to all alternate sign modes. But I am just happy to be able to use puppet and delusion at the same time now. It was driving me crazy to have to choose between them.
 

ymgve

Poser
#8
Same problem here. I noticed it does NOT affect casting with a controller, and also noticed that setting frame limit to 30 FPS fixed the problem.

Gonna try the edit posted above as a workaround until it's properly fixed.
 

OzzyEyekon

Poser
#10
i have the same keyboard(nice choice btw) and the exact same issue only i've remapped it to cast using my mouse so i dont thinks its your KB. which is especially annoying since i've just used a few "greater Axii upgrades" on my armour for this purpose. im on the GOG version.
 
#12
just to clarify...this fix enables us to have both puppet and delusion usable by having both slotted? We still have to hold down the key to cast the alternate mode right?
 

sjacksonauto

Poser
#13
Does anyone know if this will be fixed in the next patch? I have the game alt+tabbed right now and came here becasue of this bug. I am glad there is a fix here, but it still doesn't work with controller according to other posts. I have alternate igni and it works fine, but I do not have the base armor melt spell or whatever.
 

NateJunior

Poser
#14
The bug is STILL present in the 1.05,the fix reported it works and give no problem with the other alternate signs..please fix..oh my god,how mutch it's bugged this game..the next time i hear about that only Bethesda make a bugged game...:rambo:
 
#15
I've been having this issue quite a bit as well. It seems running the game at 60fps is the issue. If I lock myself at 30 I never have any problems. Hope there's a fix sometime.

The IdleTime=0.2 -> IdleTime=0.1 trick works well, just make sure you change your input settings to read only afterwards.
 
Last edited:

DDjinn

Poser
#16
Just thought I'd post an update. Patching the game resets any fix you may have done, so you will have to redo it. Example - 1.07 patch will break your fix, simply look for all instances of -- (Action=CastSignHold,State=Duration,IdleTime=0.2) -- and change it to 0.1.
 

bradb2015

Tourist
#17
beejeez...i just found this...im using a controller to play this on pc..im not adjusting game files..especially everytime they update the game...fix your freaking game CDP..axii puppet doesnt work as intended when holding down my R2 button....it doesnt cast the alternate signs. Bug after bug after bug....
 

dusty-2011

Tourist
#18
This bug still hasn't been fixed in patch 1.11.

The workaround posted here (changing the IdleTime) does work, but this bug deserves an official fix by CD Projekt RED. There's no excuse for having to edit config files in order to get one of your signs to work...
 

SigilFey

Moderator
#20
This is a weird one, but I can confirm that it does work on some systems. I've had no issue using either M+K or a controller. It may be a ghosting issue with certain keyboards. Have you tried pressing only the "Q" button, ensuring no other buttons are depressed at the same time?

Since it seems that some people have success fiddling with timing settings, try switching the game to Fullscreen mode if you're running Windowed/Borderless -- grant as much exclusive access to the game as possible.