Performance issues with Witcher 3 ver 4.0

+
Read first how Dlss 3 works before u comment...

Hhmh... OK, pardon my ignorance then...

Let's say I wish to boost my game's performance. Please enlighten me!

Currently I have Anti-Aliasing switched OFF. I wish to turn it on, but DLSS is NOT supported for me.
Should I rather switch it ON to either FSR or TAA. Which one?
Or should I rather keep it OFF ?
.
 
first never appologize to anybody in this forum you havent done anything wrong dont worry about that guy its irrelevant
may i ask what gpu do you have
Post automatically merged:

switch to taa and play on dx11 until they fix their mess
 
Hhmh... OK, pardon my ignorance then...

Let's say I wish to boost my game's performance. Please enlighten me!

Currently I have Anti-Aliasing switched OFF. I wish to turn it on, but DLSS is NOT supported for me.
Should I rather switch it ON to either FSR or TAA. Which one?
Or should I rather keep it OFF ?
.
it's depend of ur GPU and resolution but for now it's best to play on DX11 Mode with TAAU and add HBAO+ mod (probably not working on RX 6000 series and latest AMD cards) or Improved SSAO Lighting Mod (works on any GPU).
Maybe patch will come out in this week and maybe fix DX12 mode, because of VRAM overloading with memory leak right now it's mostly unplayable for any GPU with lower then 16GB VRAM .
 
Something I found out today while messing around with settings. If you disable Hairworks, GPU power usage jumps from 320-350Watts to 400-420watts. All of a sudden GPU starts to get fully utilized, and lo-and-behold frame rate jumps by 25%.

So, even in this day and age, Hairworks implementation in this game is killing the performance.

GG nVidia and CDPR.

If there is a big bug, it definitely includes the terrible hairwoks implementation in this game.

This is on nVidia GPU BTW, before people start jumping on how it sucks on AMD hardware.

EDIT: TLDR... Try disabling Hairworks. I hope it helps you guys as well.
 
Last edited:
40 fps in Novigrad at 1440p Ultra settings (DLSS and RT Off), with a 5600x and an RTX 3060ti, is absolutely horrible.

You should've remade the game in the Cyberpunk version of the engine instead of slapping DX12 version on the old Red Engine, which used to shit itself in Novigrad if you increased the LOD too much with mods.
 
I'm playing in DX11 (patch 4.01) and I've noticed I get crazy frametime stutters when I'm moving through the world, like when I'm riding Roach. I've realised It happens when my fps is over 60. If I have the fps locked to 60fps the stuttering goes away completely and the frametime is a perfect line. In DX12 I don't get the stuttering issue and I can play with the framerate unlimited or locked but above 60fps such as 120 or 144 (although I get a lower fps in general when in DX12 mode). Using latest Nvidia drivers on an RTX 2070 Super + Ryzen 3600. I also have G-sync enabled in NVCP. Why does this only happen with DX11 mode?
 
Last edited:
I'm playing in DX11 (patch 4.01) and I've noticed I get crazy frametime stutters when I'm moving through the world, like when I'm riding Roach. I've realised It happens when my fps is over 60. If I have the fps locked to 60fps the stuttering goes away completely and the frametime is a perfect line. In DX12 I don't get the stuttering issue and I can play with the framerate unlimited or locked but above 60fps such as 120 or 144 (although I get a lower fps in general when in DX12 mode). Using latest Nvidia drivers on an RTX 2070 Super + Ryzen 3600. I also have G-sync enabled in NVCP. Why does this only happen with DX11 mode?

DX 12 version has stuff that helps with G-Sync where DX 11 does not. Go into NVCP and create a profile for the DX 11 version of Witcher 3 and set your low latency option to Ultra. See if that helps you.
 
Dx11 is also a mess with this version. CPU is also not well used. I rollback to 1.32 with mods and it's way better in all ways
 
Dx11 is also a mess with this version. CPU is also not well used. I rollback to 1.32 with mods and it's way better in all ways
What do you mean by its not well used? Seems to be running pretty well CPU efficiency wise on DX 11 on all of my tests. Currently running the game on DX 11 modded at 4k and settings way beyond Ultra+ like 15,000 grass density without any CPU issues at all.
 
DX 12 version has stuff that helps with G-Sync where DX 11 does not. Go into NVCP and create a profile for the DX 11 version of Witcher 3 and set your low latency option to Ultra. See if that helps you.
Thanks for the reply. I'll give this a try.
Post automatically merged:

DX 12 version has stuff that helps with G-Sync where DX 11 does not. Go into NVCP and create a profile for the DX 11 version of Witcher 3 and set your low latency option to Ultra. See if that helps you.
It worked thanks a lot! setting Low Latency Mode to Ultra fixed stuttering in DX11 mode when using G-Sync (just for anyone else who may have this issue).
 
Last edited:
Thanks for the reply. I'll give this a try.
Post automatically merged:


It worked thanks a lot! setting Low Latency Mode to Ultra fixed stuttering in DX11 mode when using G-Sync (just for anyone else who may have this issue).
If you are looking for even more stability on the framerate and timing...
  1. Turn off framerate limiters in game
  2. get yourself MSI Afterburner/Rivatuner
  3. go to this website in Chrome https://www.testufo.com/refreshrate
  4. Set the decimal to 5 digits out
  5. let it run for 5 minutes without doing anything on your pc and no tabs opened
  6. take the value it calculated for you and enter it into your Rivatuner frame cap
  7. Test that
That setup works well for vsync and general usage...you can go even further for g-sync or games with frametime issues by using that value and subtracting 0.02 from it and using that for your cap. Example...refreshrate is 59.99833...you would use 59.97833.

Hope that helps you further.
 
If you are looking for even more stability on the framerate and timing...
  1. Turn off framerate limiters in game
  2. get yourself MSI Afterburner/Rivatuner
  3. go to this website in Chrome https://www.testufo.com/refreshrate
  4. Set the decimal to 5 digits out
  5. let it run for 5 minutes without doing anything on your pc and no tabs opened
  6. take the value it calculated for you and enter it into your Rivatuner frame cap
  7. Test that
That setup works well for vsync and general usage...you can go even further for g-sync or games with frametime issues by using that value and subtracting 0.02 from it and using that for your cap. Example...refreshrate is 59.99833...you would use 59.97833.

Hope that helps you further.
Thanks for the info, I did the refresh rate test. My value after 5 min was 144.00281 (144hz monitor) then minus 0.02 I have 143.98281. I'll just mention that I do use already use msi afterburner and rivatuner and because I always generally have g-sync enabled, I usually set an fps cap value of 141 in games (unless they have an in game limiter where I can set a specific value). So normally it's -3 fps of my monitor refresh rate so the framerate stays within the monitors g-sync range. This is based on a blurbusters g-sync guide. Some games I've noticed however will automatically cap my fps to 138. Not sure if this a dx12 thing or just the game somehow knows I'm using g-sync and sets this value. It actually happens (138 fps cap) if I play Witcher 3 in DX12 mode. Also I always set in game limiter to unlimited in Witcher 3.

edit - Also regarding the 141 fps cap. Admittedly I should probably use a lower cap for games where I'm nowhere near hitting 144fps and going over the g-sync range. In Witcher 3 I get on average 60-90fps depending on the area. Having a cap of 141 increases latency right?)
 
Last edited:
Thanks for the info, I did the refresh rate test. My value after 5 min was 144.00281 (144hz monitor) then minus 0.02 I have 143.98281. I'll just mention that I do use already use msi afterburner and rivatuner and because I always generally have g-sync enabled, I usually set an fps cap value of 141 in games (unless they have an in game limiter where I can set a specific value). So normally it's -3 fps of my monitor refresh rate so the framerate stays within the monitors g-sync range. This is based on a blurbusters g-sync guide. Some games I've noticed however will automatically cap my fps to 138. Not sure if this a dx12 thing or just the game somehow knows I'm using g-sync and sets this value. It actually happens (138 fps cap) if I play Witcher 3 in DX12 mode. Also I always set in game limiter to unlimited in Witcher 3.

edit - Also regarding the 141 fps cap. Admittedly I should probably use a lower cap for games where I'm nowhere near hitting 144fps and going over the g-sync range. In Witcher 3 I get on average 60-90fps depending on the area. Having a cap of 141 increases latency right?)
Yes it increases latency...but this is a different type of game. Ultimately this is up to you on this one, but I personally wouldnt want to play an RPG game like the witcher at such high speeds. FPS games on mouse and keyboard? Yes. Some people even find 60fps too fast for this game...even messes with the physics like the hair so you have to get a mod to fix it to run properly at 60fps.

Again though, ultimately up to you on this one.
 
Yes it increases latency...but this is a different type of game. Ultimately this is up to you on this one, but I personally wouldnt want to play an RPG game like the witcher at such high speeds. FPS games on mouse and keyboard? Yes. Some people even find 60fps too fast for this game...even messes with the physics like the hair so you have to get a mod to fix it to run properly at 60fps.

Again though, ultimately up to you on this one.
Thanks for info. I like playing with higher fps just because it feels so smooth, particularly when panning camera with mouse but ofc 60fps is fine. I usually play with controller anyway.
 
it's depend of ur GPU and resolution but for now it's best to play on DX11 Mode with TAAU and add HBAO+ mod (probably not working on RX 6000 series and latest AMD cards) or Improved SSAO Lighting Mod (works on any GPU).
Maybe patch will come out in this week and maybe fix DX12 mode, because of VRAM overloading with memory leak right now it's mostly unplayable for any GPU with lower then 16GB VRAM .

Thanks for your advice, but...
Both in 4.00 and 4.01 I figured that playing the DX11 version of the .exe with Anti-Aliasing turned OFF is THE WAY TO GO for me.

And, frankly, I don't see how it can be any other way:
If I'm already experiencing severe performance issues,
I don't see how your advice of "activate this demanding graphics setting !!" can actually be... beneficial to my peformance ?!

Though, to be fair, I never bothered with any mods running in conjunction. And I intend to keep it that way. :)
edit
.
 
Last edited by a moderator:
Top Bottom