Witcher 3 NG Ray Tracing - GPU PCI-E Bus / VRAM Overload cause of FPS drop/stuttering issue - FIX'ed!

+
Witcher 3 Next Gen DX12 mode with RT On is very VRAM Heavy. It can adress maybe more then ~ 16GB VRAM to your GPU.

Becaus of that RT On in some areas could be unplayable on GPU with lower then 16GB VRAM memory (or even them can sometimes happend this issue ).

My laptop Asus TUF Gaming A15 FA506 config:
1672501395915.png


When i start game with RT On + optimized RT (with default settings it's even worse) end after while of runing around in not memory heavy areas my FPS holds stady around 50 FPS and my GPU 6GB VRAM is load around 90%, GPU PCI-e Bus load is around 20%:

First 5 min ruing around after game start.png

But when I go to e.g. Novigrad center then after while my GPU VRAM is gets overload around 95% near maximum, and form that point game starts leaks data to shared memory of W3 and game process will starts growing, thats causing GPU PCI-e Bus overload to around 60-70% and then FPS starts stuttering with heavy drop to ~20:

after while going to center VRAM get overload, then shered memory growing and GPU PCI-E Bus st...png

and time after time runing around FPS will drops to even worse to few frames/s with horrible stuttering:
GPU PCI-E Bus Overload, shared memory growing, FPS drop to few frames.png


When I returned to the starting point FPS won't recover even if VRAM usage is lowered, still GPU Bus PCI-E will be overload, same shared memory:
Going back to starting place, FPS won't recover, GPU Bus PCI-E still overload, same VRAM and s...png


This problem won't stop till restart game.

It no fix for that, but I notice only slight improvement when i change virtual memory size from Auto to e.g. 32 GB and when i enabled Resizable BAR Support in Nvidia profile inspector.

If you have same problem, then check if ur graphic card working on full PCI-E Bus interface x16, otherwise it will throttle PCI-E Bus throughput like in my example.

in my laptop is limited more then half, it should be PCI-E x16 4.0, but i it's only x8 3.0 becaus of AMD chipset idea... (maybe if i remove one of two SSD m.2 it will be x16, i have to try it).

EDIT: Memory leak can be fixed! More info here:
 
Last edited:
Imagine you look at this:
system req.jpg

and this:
Nvidia.jpg

you go buy a super expensive piece of technology: a 1000$ RTX 3080 10GB . You think you are set playing the new Witcher 3 Next Gen at high resolutions and high frames with RT, DLSS.
And you go home thinking your gonna have fun and enjoy the game only to be greeted with 30 FPS , stutter, crashes, artifacts at first and then after a while with unplayable frames below 10 fps thanks to bad resource management and bad optimization.
1080p RT RTX 3080.jpg

One starts to think if these gaming companies really cares at all about their customers: the gamers? :sad:
 
With ur rtx 3080 u could get ~60 Fps in most places with optimized RT. Check mine guide and u will gain around 2x more fps with minimal quality loose.

It will not solve problem with overload VRAM/GPU PCI-e when ur GPU VRAM reach maximum, but it may reduce its occurrence.
 
Last edited:
Have you tried using GPU-Z just to check nothing weird happens with the PCIe bus interface while W3 is running?

Could any power/thermal management options be kicking-in to throttle the interface?
 
Having similar issues with my desktop (AMD 5900X and an RTX 3080 etc) I can assure you, at least in my personal case, it has ZERO to do with thermals
 
Hopefully they're still working to get the game better optimized because it is demanding huge GPU resources right now. I'm running an ASUS TUFF 4080/Ryzen 5600x with all the options turned up to 11 (including ray tracing) @ 1440p and it's banging out a 130 fps. No complaints there. The trouble I'm having is during the cut scenes. They stutter and lag and freeze and then the dialog/lip movement goes all out of sync. Not a game breaker, but it's pretty damned annoying.
 
Last edited:
Have you tried using GPU-Z just to check nothing weird happens with the PCIe bus interface while W3 is running?

Could any power/thermal management options be kicking-in to throttle the interface?
It's not termal issue, look at that 1 minute after game start:

everything works normally till VRAM reach over 95% of usage and in that moment and GPU Bus started to grow from 15-20% to ~40% and more:
moment of GPU VRAM overload and GPU Bus overload .png

cause of data transfer from GPU VRAM to many times slower shared memory (RAM + page file on disk ) and because of this there is a terrible fps drop to ~20 FPS:
few secunds later.png

and after staying few minutes in this place, shared memory grove to over 6GB+ and load of GPU PCI-e Bus reached ~80%, FPS drop even more to 0-7 frames/s:
:
another few minutes staying in this place.png


This VRAM Overload causing memory leaking to horrible slow system shared memory, overloading GPU PCI-E Bus. For my point it's bigger problem than very low CPU core/threads usage in DX12 mode, that CDP have to also fix but in first place should be this VRAM overload issue or this game with RT will be forever unplayable on something slower then RTX 3090...
 

Attachments

  • First minute after game start.png
    First minute after game start.png
    3.2 MB · Views: 3,389
Last edited:
The first image does show GPU-Z reporting the 'PerfCap Reason' as being thermal and a high power consumption (113%)? Maybe worth giving all the vents etc a good blow-out and turning off overclocking (if any) of GPU and CPU while investigating? I'm on a desktop now but used to have an old gaming laptop (or what passed for one) and dust build-up was a problem.

Sorry if it sounds like I'm looking too hard for reasons other than VRAM, just that other reasons might be more easily fixed! I have 8GB VRAM and usage seems to hover very close to 6GB, I don't see it trying to grow over time but maybe 6GB on the card really is a problem. Report to CDPR?
 
The first image does show GPU-Z reporting the 'PerfCap Reason' as being thermal and a high power consumption (113%)? Maybe worth giving all the vents etc a good blow-out and turning off overclocking (if any) of GPU and CPU while investigating? I'm on a desktop now but used to have an old gaming laptop (or what passed for one) and dust build-up was a problem.

Sorry if it sounds like I'm looking too hard for reasons other than VRAM, just that other reasons might be more easily fixed! I have 8GB VRAM and usage seems to hover very close to 6GB, I don't see it trying to grow over time but maybe 6GB on the card really is a problem. Report to CDPR?
Raports are ok, no o/c and like i sad it's laptop, showing Pwr/Thrm limits on PerfCap Reasons it normal behavior and it's not the reasons of this problem.

Did you run ur game at Ultra+ with Full RT? Have you been in Novigrad center and there run around for 15-20 min, like on my screenshots??

Maybe Novigrad is not the most demanding place but in some cases this game could load even near to 16GB VRAM.

And yes, raported to CDPR on begining of this thread.
 
Last edited:
Memory controller load is very low,
It means that the video card does not read data from Vram at all,
All data is read from RAM,
Pci-e is naturally busy.
And because there is no data and the chip does not work, the frame number will be low
 
Memory controller load is very low,
It means that the video card does not read data from Vram at all,
All data is read from RAM,
Pci-e is naturally busy.
And because there is no data and the chip does not work, the frame number will be low
Not exacly, in beginig of gameplay GPU memory Controler is wokring fine with ~40% usage but only till VRAM is not overload.
When VRAM reach near maximum usage, then graphic card starts loading only small part data to physical RAM w and the other, bigger part to many times slower virtual memory in ur disk. Thats why mem. controler is lowering usage and GPU PCI-e Bus is overloaded with readings and transfering data coming from and to 3 places and thats why is bussy. Video card reads from VRAM but only some low part of data, the rest of it have to read from RAM and the biggest part from the slowest shared virtual memory... That results is FPS drop to even 0.
It's unacceptable that the testing department let this pass.
 
Last edited:
Hopefully they're still working to get the game better optimized because it is demanding huge GPU resources right now. I'm running an ASUS TUFF 4080/Ryzen 5600x with all the options turned up to 11 (including ray tracing) @ 1440p and it's banging out a 130 fps. No complaints there. The trouble I'm having problems is during the cut scenes. They stutter and lag and freeze and then the dialog/lip movement goes all out of sync. Not a game breaker, but it's pretty damned annoying.
I HAVE A BIG PROBLEM WHEN ACTIVE DLSS GENERATION MY GAME DROP FPS IN SOME PARTS OF MAP SO BAD 100 DROP TO 10 IDK WHY IS GOING ON WITH NEW DLSS GENE
Post automatically merged:

someone knows why when i active dlls generation 3.0 on my 4080 the fps drops sometimes 100 fps to 10 or even 0 only when i active new dlss 3.0
 
I HAVE A BIG PROBLEM WHEN ACTIVE DLSS GENERATION MY GAME DROP FPS IN SOME PARTS OF MAP SO BAD 100 DROP TO 10 IDK WHY IS GOING ON WITH NEW DLSS GENE
Post automatically merged:

someone knows why when i active dlls generation 3.0 on my 4080 the fps drops sometimes 100 fps to 10 or even 0 only when i active new dlss 3.0
Did you read this thread? Most probably ur GPU reach maximum load of 16GB VRAM and thats why u got only few frames even with Dlss 3.0, read my post before, run GPU-Z and observe GPU VRAM and GPU Bus usage.
 
Last edited:
¿Leíste este hilo? Lo más probable es que su GPU alcance la carga máxima de 16 GB de VRAM y es por eso que solo tiene unos pocos fotogramas incluso con Dlss 3.0, lea mi publicación anterior, ejecute GPU-Z y observe el uso de GPU VRAM y GPU Bus.Pero ingenio

Did you read this thread? Most probably ur GPU reach maximum load of 16GB VRAM and thats why u got only few frames even with Dlss 3.0, read my post before, run GPU-Z and observe GPU VRAM and GPU Bus usage.
so how i can solve it , and why when i off dlls 3.0 work better its funny hows that happen with rtx 4080
 
so how i can solve it , and why when i off dlls 3.0 work better its funny hows that happen with rtx 4080
Probably Dlss 3.0 using more vram, u need to check that. It's no fix for that till CDP Red release fix for it, if will be ever fixed... yea is funny or sad if this issue happening on 4080...
Post automatically merged:

But u could Just use optimized RT settings to get ~60 fps without DLSS 3.0 frame generator. Check my guide about it:
 
Last edited:
so how i can solve it , and why when i off dlls 3.0 work better its funny hows that happen with rtx 4080
We gotta play the waiting game now. Till CDPR get it together and fixes the game.
I just tried the game for like 30 min and stopped after. The performance was ridiculous. I only have a GTX 1060.
I knew I had no hope to play when I saw people with RTX 3000 and 4000 series complaining.
 
We gotta play the waiting game now. Till CDPR get it together and fixes the game.
I just tried the game for like 30 min and stopped after. The performance was ridiculous. I only have a GTX 1060.
I knew I had no hope to play when I saw people with RTX 3000 and 4000 series complaining.
But i don't think this issue is related to dx11 mode and without RT there is no other reason and benefits from using DX12 Mode (even u got decress preformance from much lower cpu core/thread usage), especially for older cards like gtx series without rt support.
 
Raports are ok, no o/c and like i sad it's laptop, showing Pwr/Thrm limits on PerfCap Reasons it normal behavior and it's not the reasons of this problem.

Did you run ur game at Ultra+ with Full RT? Have you been in Novigrad center and there run around for 15-20 min, like on my screenshots??

Maybe Novigrad is not the most demanding place but in some cases this game could load even near to 16GB VRAM.

And yes, raported to CDPR on begining of this thread.
Yes, all RT options on, everything turned up to max. This is just for testing the VRAM usage, performance is not great overall (40-50 fps), but it seems consistent. On my system it looks like VRAM is being well-managed: it's allocating most of the card's 8 GB as it can. I guess on a 16 GB card it would do ther same, I don't see any problem with that. Most importantly, I don't seen the VRAM usage growing out of control. But no, not been in Novigrad yet, early-on in first playthrough so will see.

Got no answers I'm afraid. I can't think of any hardware settings which might explain your different experience.
 
Yes, all RT options on, everything turned up to max. This is just for testing the VRAM usage, performance is not great overall (40-50 fps), but it seems consistent. On my system it looks like VRAM is being well-managed: it's allocating most of the card's 8 GB as it can. I guess on a 16 GB card it would do ther same, I don't see any problem with that. Most importantly, I don't seen the VRAM usage growing out of control. But no, not been in Novigrad yet, early-on in first playthrough so will see.

Got no answers I'm afraid. I can't think of any hardware settings which might explain your different experience.
No suprise if u didn't even go to havy place scenerio like Novigrad. Your game progress doesn't matter, just run new game and choose form "Hearts of Stone" and Just go to Novigrad, it's that simple...
 
Last edited:
I can confirm this (RTX 3070). Depending on the environment, object and light source density, there are permanent FPS drops. Sometimes a reload helps, sometimes only a restart.

At least I get 30 to 75 FPS (capped) with the tweaks, depending on the scene. I wouldn't want to miss RT, especially indoors and cut scenes. That is significant improvement.
 
Top Bottom