I simply lowered the resolution and it fixed itself. In the highest available resolution, it would unsync, even in low video settings. Dropped resolution...