"Not enough free disk space"

Maybe I am extremelys stupid and missing something very obvious. But a friend told me there was a new small hotfix and I was gonna download it. But I have the same issue as before (on launch I had to uninstall the entire game from scratch and "lost" my preload).

I have about 53gb free on my SSD, but still get that "Not enough frees space"-messege when I try to get the last, small, update. Any ideas? Easy solutions to this? I dont wanna delete stuff anymore to get a small update for the game.


  • cp1.png
    11.7 KB · Views: 417
Same issue, I deleted everything to get 119 Go of free space on my SSD raid cluster.

Now GOG is downloading the update ... 63 Go !



  • Cyberpunk2077_update.jpg
    106.4 KB · Views: 344
For me, GOG is basically redownloading the entire game. It explains why there is still a "not enough space" error with plenty of free space on disk.

Edit : the size of the Cyberpunk 2077 folder on my disk is currently 128 Go (my update is at 68 %).

Edit2 : update done, final size of Cyberpunk 2077 folder : 64.2 Go. Version number is correct (1.04).

Keybinding issues, flatlined crashs every 30 minutes, and now this. What a launch. But the game itself is amazing.
Last edited:


Forum regular
Same here. There's a clear bug here but possibly in Gog Galaxy rather than in Cyberpunk.

I've just suffered the issue with hotfix 1.04 which is just about 600 MB. But it seems GOG Galaxy needs about 65 GB of free space (the full software size at least in my installation with Spanish localization as extra)... Therefore Cyberpunk needs about 65 GB of disk space in order to install but about 130 GB in order to stay updated... This is crazy.

And yes, while the software is being updated ALL those 130 GB are used (I insist hotfix 1.04 is smaller than 600 MB). Look at the screenshot I've taken while the software is being updated. That !Temp folder is not nice...
Look at !Temp Folder.jpg

Something is clearly NOT optimized here.

(Well, at least I've done a lot of manual rubbish cleanning in my "small" SSD drive in order to get all those stupid free GB...)
Last edited:
The same problem. I use SSD - 116 GB of free space. After installing the game, 52.2 GB remains free. But after each update GOG gives an error - "There is not enough space on the disk". So I just have to reinstall the game from scratch. Why is this so and will it be fixed in the future?


Can only confirm what others have said above me. My computer wizard friend help me clear up some junk space on my SSD so I was able to finally download that 585mb update.

During that SMALL update I had 10,7gb space free on my SSD.
Now that the update is complete I have 71gb space free on my SSD.
So no I idea why it has to allocate that much space during that minimal download.

Hopefully future updates dont behave in this manner and it is something GoG can take a look at.
Can only echo what people have already said. I had to completely uninstall the game to get the hotfix update (I say get, but it's still downloading). It very clearly has nothing to do with the servers being down or so, because I had no problems starting the re-download.

Conversely, no one I know that has the game on Steam has any issues updating. At least not to my knowledge.
I have over 800 GB of free space on my installation drive and I'm still getting this same error. There has to be a bigger technical problem going on here with patch installation or disk space allocation.

Update failed (E8)
Not enough free disk space in <drive>
I have over 800 GB of free space on my installation drive and I'm still getting this same error. There has to be a bigger technical problem going on here with patch installation or disk space allocation.
I fear yours is a different issue...

GOG Galaxy basically doubles game size while updating (other user says Steam version does not suffer the issue). But you are suffering something different
This is the answer, any storage needs some 'headroom'. 20% space is sensible.

But that doesnt really apply in this situation. If I have an SSD with say 225gb and I have 60gb freed. I should still be able to install a 585mb update. I have no clue why they allocate so much space for that minimal download. So how is this "the answer". Enlighten me please.
Because it has to unpack those files to add it in. There is not enough space to unpack.
I was also using a smallish SSD (119 GB) with nothing else on it and 59.3GB free.

To get the update to install I went into Cyberpunk\archive\pc\content

and deleted lang_en_voice.archive (4.8GB) this seemed to let the download and install work ok.

I have the same problem only in Steam. In fact, I am surprised that there are so few complaints about this on the forum. Redirect more message. For example https://www.reddit.com/r/gog/comments/k9w7cw It's been two weeks now. Several hotfixes have been released. But an adequate update of the game files has not been implemented.
Should we expect any improvements in this direction?
Top Bottom