Trevor's Last Ride is still bugged in 1.6 (body spawns but "Find Trevor's Body" objective does not update)

Trevor's body spawns in the ice bath. However, when approaching/scanning it, the objective does not update. If I run out of the Wraith camp completely, Johnny suddenly speaks up saying something along the lines of "What do we have here?"

Once I hear Johnny's line if i run back to Trevor's body, Johnny is standing there. However, picking up Trevor's body still does not update the 'find body' objective or trigger any more dialogue with Johnny.

This is my original save file which I started at launch on PC and quit playing before doing The Heist in Arasaka Tower. I've tried reloading the save prior to when Dakota calls me and either completing or not completing the investigatory steps (car, blood stains, reading the datashard on the Wraith, etc) and none of that has an effect. Each time i get to 'Find Trevor's Body' the gig becomes 100% blocked and I cannot find a workaround. There were workarounds for the previous issue but this new fix in 1.6 has completely blocked the gig for me, which is blocking multiple tiers of Dakota's gigs.

I cannot even seem to get this gig to complete with a save editor as there does not appear to be a quest fact for find body, only "take body" which I've tried manaully advancing with no effect, either. I waited 2 years to try this game again and was having a blast until hitting this issue. I thought, surely, after 2 years issues this serious would be fixed. My guess is that I should have started a new save, but I shouldn't have to do that.

I can't remember if 'take body' advances when doing this naturally. I've already spent a couple hours trying to get this gig to update and I don't feel like doing any more free work on this. If a dev sees this, I am sure they can figure it out as it's clearly a very simple logic error in the quest of some kind.

Last edited:
I had the same problem and was a bit lost in the save editor, but thanks to the picture I managed to sort it out, I had to add ina_08_finshed and change it to 1, then I used "simple menu" mod to force the quest to end, this finished the quest and updated Dakota. I also had a bug with MIA, and had to add ina_05_start and ina_05_finished then use "Simple menu again", the last of Dakota's missions are now showing.
Last edited:
I'm having this same problem. Got to "Find Trevor's Body", and now it's locked and won't progress....gonna try the save editor just so I can get past it. I just want to do all the gigs and side missions.
I’m having the same issue. I tried all the work around a but his body will not spawn. I’m on Xbox series X
Top Bottom