Game has no anti-aliasing option

+
Title says it all, I wanna turn off the anti-aliasing and the game doesn't have that option; games on my PC with anti-aliasing look blurry so I turn it off, I'm not gonna play the game with it looking like THIS (JUST LOOK AT THE HAIR)
 

Attachments

  • unknown.png
    unknown.png
    3.2 MB · Views: 13,166
You can usually turn that off in AMD software on my graphics card so it will force it off even if its not an option in game.
 
You can usually turn that off in AMD software on my graphics card so it will force it off even if its not an option in game.

I don't have an AMD card and I already turned it off in nvidia panel but it didn't do anything
 
It is a very big oversight, I can tell it's a very heavy AA pushed on this game which will make it worse when I bump up the resolution. I use a higher resolution at the expense of AA, but this is the first game in many years that I've loaded that is missing the option... kinda strange really, unless AA is buried in the game engine and needs to always be on, a console porting issue?
 
If you have NVIDIA, I've found a way to make the game less blurry at no performance cost.

You need to activate the game overlay in GeForce Experience. Then, once you are in the game, you need to press ALT+Z and click on "Game Filter" (Or press ALT+F3 for the shortcut).

Then, you simply add the filter "Details". Then you just play with those settings. I personnally put Sharpen and Clarity at 100% and HDR Toning and Bloom at 0%. The game look less blurry and I didn't even lose any FPS in the process!

I hope they will give us the option to remove the AA if they don't want to give us different option for it, I hate TAA...
 
Hey, so I dug around in the files, they have "Dynamic AntiAliasing" or so i saw in the UserSettings.json. I say "Dynamic Antialiasing" because it has the default value to 'true' for 'is_dynamic'. I set the 'value' to off, i have no clue at this time what the actual value should be to turn it off, nor do I know what value there should be for the index. right now im just kinda pissing in the wind. the game looks great, but i feel as though with the AA being dynamic, it just rams its horse coccyx right into the performance. i think they meant to incorporate something into it, but I have no clue as to what setting its initially tied in with. If the value i set doesnt work, im going to remove it all together, and see if I have better FPS. I have a 1070ti and am able to run almost all games without AA at around 100fps @ 1080, so booting up this game and getting barely 48 was a real kick in the e-peen.

Edit: I edited the user settings, values reset to default when you launch into the game because it is now "corrupted". It looks like they meant to include the slider, but forgot.

another update, its set to 'is_dynamic' because the intended purpose was for you to be able to change it. However, the index is -1 and there is no value in there by default. If anyone can help, itd be appreciated
 
Last edited:
This is really bad. I didn't play outer worlds because of this and will refund this game until they fix it. I shouldn't have to look through a million ini files to make the game not look like a blurry mess.
 
"name": "AntiAliasing",
"display_name": "UI-Settings-Video-Advanced-AntiAliasing",
"description": "LocKey#72353",
"order": 13,
"is_visible": true, <---- false by default
"in_pre_game": true,
"in_game": true,
"update_policy": "immediately",
"type": "string_list",
"is_dynamic": true
},

There is a legit option in the game for it. It ends up being blank because they have no values established for it

This was in "INSTALLPATH"\Cyberpunk 2077\r6\config\settings\platform\pc options.json
Can someone help with a fix?
 

Attachments

  • 1091500_screenshots_20201209230728_1.jpg
    1091500_screenshots_20201209230728_1.jpg
    196.1 KB · Views: 5,693
Last edited:
Same problem here. The TAA (Temporary Anti Aliasing) technic is just broken on many systems. And there are some games, like The Outer Worlds and Cyberpunk 2077 that completely rely on TAA. Almost all my borders are flickering, the hairs are all shimmering, shadows are broken... Only fix avaiable is to deactivate AA and then use Reshade to get another, working kind of AA. But how to deactivate it? Bad enough they used a AA technic that is broken on many systems , but then its also impossbible to deactivate/fix it... Grrrr.
 
I have to say (and I really am almost crying because of it :cry:) I am disappointed... I have to reduce the render scale to hit 60 fps, but then the game looks like a blurry mess -- I'm pretty sure it would look better with some control over the AA settings, or simply disabling them and let my GPU handle that. So the choices are to let the game run like molasses, or have it look like I'm seeing through a window covered in a thin layer of Vaseline. Somebody dropped the ball here with the AA settings for sure
 
"name": "AntiAliasing",
"display_name": "UI-Settings-Video-Advanced-AntiAliasing",
"description": "LocKey#72353",
"order": 13,
"is_visible": true, <---- false by default
"in_pre_game": true,
"in_game": true,
"update_policy": "immediately",
"type": "string_list",
"is_dynamic": true
},

There is a legit option in the game for it. It ends up being blank because they have no values established for it

This was in "INSTALLPATH"\Cyberpunk 2077\r6\config\settings\platform\pc options.json
Can someone help with a fix?
You can set it to a bool and have it turn off or on but it doesn't seem to do anything... such a shame
 
Cyberpunk uses a lot of TAA.
Most TAA implementations have "ghosting problems".
it's very difficult to avoid them and thats the reason why a lot of games don't use TAA.
The Hair looks smeared and thats how you can tell for sure.
You can simply switch to another method if the game supports it.
a lot of areas benefit from Anti Aliasing even if you don't recognize the aliasing artifacts,
because you are so used to them by now.
a popular example of "heavy ghosting" would be Black Dessert Online.

example tweet:
 
Cyberpunk uses a lot of TAA.
Most TAA implementations have "ghosting problems".
it's very difficult to avoid them and thats the reason why a lot of games don't use TAA.
The Hair looks smeared and thats how you can tell for sure.
You can simply switch to another method if the game supports it.
a lot of areas benefit from Anti Aliasing even if you don't recognize the aliasing artifacts,
because you are so used to them by now.
a popular example of "heavy ghosting" would be Black Dessert Online.

example tweet:
It's sad that many games these days rely on TAA... RDR2 does the same thing. TAA fixes a lot of shadow related issues but when you disable it they become pure noise or grainy, they also used it to blend between frames in motion to stop trees artifacting or shimmering. When the game is designed around TAA... there's little to nothing we can do as consumers to mitigate the effects unless they actually improve their AA solution and remove the restraints. SMAA is powerful and looks better in most instances without the added blur but again it depends how it's applied.
 
I would like a simple ability to completely switch off the anti-aliasing. On Radeon I cannot override AA to disable it. On low settings FPS oscillates around 14. This is a massive oversight.
It's because it's a terrible port... with developers that are more focused on making the NEXT GEN version be the sparkling new gem... for a PC centric developer to shaft the PC version like this... it's a pure scam move. It was already delayed by over a year and this is the port they give us???

I'm having issues with the contrast being totally broken as well as horrible FPS... most scenes are blown out (mostly or over saturated by white). It's more than an oversight... it's blatant disregard for optimisation.
 
Top Bottom