Massive CPU / RT Related Performance Woes after 2.1 Update

I'm experiencing a rather severe CPU bottleneck problem that I initially thought I had narrowed down to Ray Reconstruction but is now happening whether or not that is enabled or not, or, maybe it's situational and some scenes / environments are so demanding that it's dipping down even with it disabled.

I posted this over in the game's Steam Discussion forum and now, having ruled everything out, with no other CPU or Memory consuming processes running, with the game's executable running with Very High privileges in Task Manager, I'm left to conclude that there is nothing that can be done about this performance issue short of reverting to an earlier build pre-2.01, it just sucks because I just spent like 45 minutes creating a new character and have already invested roughly 4-6 hours in a new play-through and all of this will not be compatible reverting to say 2.02. My research is indicating that this is a fairly widespread issue affecting users with fairly robust hardware, all of which implicate RT / RT Ray Reconstruction, and Path Tracing, and I'm referring to the CPU side of things.

To describe the issue in sum, with a 12900k @ 5.1 GHz actual (0 AVX) across all P-Cores, (E-Cores disabled) and a 4090 @ 2850 MHz, both components under tons of water (45C GPU and CPU, 31C water temp, inaudible fan speed), 4x8 4000 MHz DDR4 with tight timings, basically the fastest DDR4 you can possibly use, the GPU utilization and FPS will start out at 99% and 65 FPS loading a save or coming out of the menu but within 60 seconds it will drop down to 80% and 57 FPS. I've tried turning up DLSS quality from Auto (Balanced) to Quality with the intent of at least putting the GPU to work but the utilization simply stays the same and the FPS goes down to the mid 40's. This is at 7680x2160 (dual 4K) with FG enabled, RT: Psycho, everything else maxed except Crowd Density: Med, and Ray Reconstruction and Path Tracing disabled. Initially I believed I had narrowed down this problem to Ray Reconstruction but now, as of this evening, it's presenting the same problem with it disabled. I'm in the area with the first mission with Jackie, retrieving the bot from Maelstrom, and in this area it's presenting this issue. I'm so frustrated with this that I'm ready to redownload 2.02:
Given how widespread the problem I I presume the devs are aware of the issue? Read the comments below the following video showing the FPS drop between 2.0 and 2.1.
If I could use all 99% of my GPU that would be fantastic, oh and when it dips down to 80% after 30 seconds of loading a save or exiting a menu the CPU usage is at 20%, golf clap. I have other gripes with this update, I tried to help NCPD fight some goons and didn't shoot at them at all and after I helped them dispatch the goons they all went completely agro on me? Also, the "there are actions without key-binds" bug is super annoying.

My original Steam thread:

DLSS Ray Reconstruction causing performance to drop after patch 2.1
I have this very same problem and independently narrowed down the issue to Ray Reconstruction. The issue occurs separate from Path Tracing, simply enabling Ray Reconstruction with RT causes my CPU utilization to drop from 95% down to 80% (12900k @ 5.1 GHz, E-Cores disabled, 32GB 4000 MHz DDR4). This drops my FPS from a completely playable 65 FPS to 55-57 FPS when it happens (7680x2160, RTX 4090 under water block @ 2850 MHz, FG enabled, DLSS Auto).

For whatever reason there is also flickering with Ray Reconstruction enabled? This problem wasn't present before the latest patch, in fact, I was around 65 FPS with Ray Reconstruction enabled without the CPU bottleneck (RT: Psycho).

Any way to pass this on to the devs? Are they aware of the issue? Thanks.
If you think this is bad, load up 1.63 when Path Tracing wasn't broken. Performance was reliable and it actually worked.
If you think this is bad, load up 1.63 when Path Tracing wasn't broken. Performance was reliable and it actually worked.
I'm actually considering rolling back to a version of the game that doesn't destroy performance when RT is enabled. Having updated to 2.11, the performance impact of Ray Reconstruction is still present. I have some more data to share in regards to this problem. Last night, before updating from 2.1 to 2.11 doing the benchmark's back to back disabling and enabling Ray Reconstruction the conclusion was that with Ray Reconstruction enabled (not Path Tracing, just RR) the GPU ran around 80% roughly 5-10 seconds after the start of the benchmark (still in the bar) with the FPS around 60. With RR disabled (RT enabled, Psycho) the GPU utilization stayed near 90%, sometimes flirting with 95%, and the FPS was similarly 10% higher. What is interesting is that at the end of the benchmark the RR enabled yields a higher score, with more frames rendered, but if you sit there and actually watch the bench with RR disabled it's roughly 10% more FPS throughout the entire bench, so the end result is bugged. The same behavior carries over into actual loaded game-world.

Last night I also enabled the E-Cores on my 12900k and this seemed to up my FPS by 5 or so. Today, after updating to 2.11 with E-Cores enabled the GPU utilization is pegged throughout the benchmark (4090 @ 2900 MHz) yielding a remarkable (for dual 4K) 80 FPS avg. Sadly, my system is not stable with the E-Cores enabled and it also presents the additional unwanted behavior of not downclocking the CPU freq, voltage and power. With the E-Cores disabled it will drop down to 1.6 GHz even with a web browser open, and power consumption doesn't exceed 110w @ .795v. With the E-Cores enabled, it will sit at 5.1 GHz and 1.4v with just a web browser open and nothing else going on (1% usage) and power consumption is around 150w. I've tried to resolve the issue re-enabling C-States but it doesn't seem to matter what I do with the E-Cores enabled it refuses to chill out under low load. I have already sorted out the Windows Power Plan settings (Balanced min processor state: 5%, High Performance: 100%).

So if you have E-Cores, there's definitely a big performance improvement with 2.11 leaving them enabled.

I may play around with it some more, try dialing back AVX512 offset. Been messing with it all morning, I need to go for a walk.

But yeah, even with E-Cores enabled on 2.11 the CPU usage sits around 80% in the benchmark and the actual game-world with Ray Reconstruction so this really is a CPU impactful setting. Not sure why it's so CPU demanding, Nvidia has used this game to kind of showcase a performance improvement with it but all I'm seeing is a degradation. It does deal with light better, but it's not worth my FPS tanking from 65-70 to 55-60 because of the CPU bottleneck it induces.

I recently upgraded from 12900k to 7800x3D and this issue is still present. Thinking that my CPU bottlenecking days were over at 32:9 with Path Tracing enabled I was somewhat dismayed to find that in Liberty City @ 7680x2160 (DLSS: Performance) my FPS would still exhibit the same behavior as the 12900k, and this is a big problem because loading a save and the performance starts out with 99% GPU utilization (4090 @ 2900 MHz) and playable 60 FPS and then within a matter of 10-15 seconds drops down to 90 and then eventually 80% utilization and my FPS is at 47-50 FPS, which is NOT playable (this is with FG enabled). So after hours of troubleshooting, overclocking and undervolting my 7800X3D, playing around with power plans, trying the performance in both Win10 and Win11, disabling HDR, I finally resolved the issue by........disabling Ray Reconstruction. With Ray Reconstruction disabled the GPU usage is pegged to 99% and it's at or above 60 FPS everywhere.

Why is no-one else complaining about this? Is Nvidia aware of the issue?
Post automatically merged:
Last edited:
Top Bottom