[AM4 PCI-E BUG] Patch 2.1

[AM4 PCI-E BUG]. Hello everyone. I don’t come here often, but today there is a reason for this. Telling the backstory

On patch 1.6 everything worked fine, but on patch 2.0 I noticed a bug with “AMD multi-threading optimization”. When I turned on this function (I was waiting for it for a long time, I just had to wait for the possibility of setting the rendering distance and FSR 3.0), for some reason the game froze after 10-15 minutes, taking Windows with it, without a blue screen, the computer froze, then went into reboot and hang on Windows initialization. End. What's funniest is "AMD multi-threading optimization" in robot mode Auto and not On. Everything worked fine on patch 2.0.

Patch 2.1 came out and with it the continuation of the story, only now the game, regardless of the settings, froze the same as before. My PC is overclocked, processor and RAM (ryzen 5600x 4.6 gh PBO curv -30 if 1867, ddr4 8x4 3733 cl16 v1.368) and everything runs on ADATA NVME SSD 512GB. I checked everything, both RAM and processor, to no avail. Only changing one setting affected the hang up to 30-40 minutes “using a slow disk”. And then the computer once again decided to freeze and I decided to wait, maybe it would work out. When I returned, I saw in front of me UEFI, which the computer should log into itself only if there is no boot disk. That's it, I thought. The SSD died, it was not in the list of drives. Turning off the power supply via the button, as usual, and turning it on, Windows started. And the SSD continued to work normally without any errors in synthetic tests.

What was wrong anyway?
The video card was connected to the processor via the PCI-E 4.0 x16 bus, but operated in PCI-E 4.0 x8 mode. Because the SSD was also connected directly to the processor via the PCI-E 4.0 x4 bus, but the SSD only supports PCI-E 3.0x4. The motherboard (apparently after some kind of UEFI update, since quite a bit of time passed between versions 1.6 and 2.1) itself turned on the PCI-E 3.0 x8x4x4 robot mode. After switching the SSD to another m2 slot everything started working fine. I had to connect the drive to the chipset and not to the processor and lose half the speed since the operating mode in this case is PCI-E 3.0 x2, because the motherboard completely refuses to work differently.

Do it yourself, I made conclusions for myself (I need to replace the main SSD with support for the PCI-E 4.0 x4 bus). I hope this information will help someone, hello, hello, developers? when is FSR 3.0 and a normally configured denoiser?
Peace to our sky.

The problem is still not solved. There may be a problem with the video card driver.
Version Adrenaline 23.12.1

The problem has been solved, the thermal interface of the video card was faulty. The "AMD simultaneous multithreading" mode works properly.
Last edited:
Top Bottom