Audio Issues (Crackling Sound)

+
Anyone else running a DAC with some mid-range enthusiast headphones? I'm getting constant pops and crackles on my HD 6XX's plugged into my Topping DX3. Tried Toslink and USB and it's starting to drive me insane. It ONLY does it in CP 2077. I've tried flushing audio drivers and reinstalling from scratch, changing audio bit rates, in game audio settings, every thing I can think of. No change. It's driving me insane.
 
Yeah mate I had the same problem. I had my audio format sample rate and bit depth set to 192KHz 24Bits and got those constant audio crackles. With the game open, I alt-tabbed to the Realtek audio console (since I have a Realtek HD audio chipset on my mobo) and changed it to 96Khz 24Bits and that fixed it instantly. I know you said you tried that but maybe try a simple speaker setup?
 
Yeah mate I had the same problem. I had my audio format sample rate and bit depth set to 192KHz 24Bits and got those constant audio crackles. With the game open, I alt-tabbed to the Realtek audio console (since I have a Realtek HD audio chipset on my mobo) and changed it to 96Khz 24Bits and that fixed it instantly. I know you said you tried that but maybe try a simple speaker setup?
I will definitely give it a try. I'm also using a Realtek chipset and I honestly hate them.
 
FWIW, I am using a Logitech Z623 2.1 speaker setup. I didn't change the sample rate in Windows, I did it in the Realtek app.
 
SOLUTION: Reduce Audio Playback device to 44.1Khz in Sound Control Panel

When I played the first hour I was having constant audio glitches that were not part of the game. These sounded to me like when a computer is having audio buffer under runs. This solution worked in another one-off tile I can't recall but reducing the sample rate of my sound card fixed the issue. I also bumped the buffersize from 256 to 512 for good measure. The above tweaks fixed the glitching for me but it's annoying having to toggle back to 48Khz to run my daily workloads (audio production). I'm running a Intel i7 8700k w/ RTX 3080 and 32GB of Ram and installation on a NVMe drive so I doubt it's my system.

**EDIT:** Just finished multi-hour long session. I occassionally hear the glitch/pop but dropping the sample rate still got rid of 95% of it. At this point I assume it's some optimization needed with CP2077's audio playback.
 
Last edited:
Hey guys,

today i wanted to start playing Cyberpunk but this sound problems keep me from toing it.
here the problem:

cpu is at about 25% on all cores while this problem apears
gpu also sleeping at 5% usage

what i already did:
resetting all ingame settings (no change of sound problems)
restarting the game (problem did not change)
restarting computer (problem did not change)
shut down computer, turn off PSU, wait a bit (problem did not change)
letting gog galaxy repair the game
--> this fixed the problem for some time, i started the game and just while the first dialouge it started again.

what i also noticed the sound distortion only appears to be on the Cyberpunk sound.
when i start music with another application the sound is good while in the distorted sound comes from cyberpunk at the same time.


so if there are any infos i can provide you with i'll be happy to

already thanks alot!
 
I am having a similar issue on PC. The crackling happens sporadically as in it will happen for a while and then stop resuming normal audio. The crackling sound actually changes the tempo of the music/dialogue when it happens on my end. it can be assumed that it's not just an output issue but actually a sound driver/processing compatibility issue that is only apparent with CP77. I have not experienced this with any other game. I tested this by running the game simultaneously with a youtube vid and it didn't occur on the external source.

My sound set up is a a sennheiser gsp 670 headset and the accompanying EPOS gaming suite
 
I had the similar issue, I have a Focusrite Scarlett 2i4 audio interface and for music production I got my rate at 48000hz, and like in Red Dead Redemption 2 I got horrible crackling sound issues here in Cyberpunk 2077. So I need to open the Focusrite Mixing options and put it lower, at 44100hz and the crackling is gone !
Everytime I'm back on my DAW for music production it goes back to 48000hz, so I always have to put it at 44100hz before launching the game.
 
I'm not having the crackling issue, but I do hear a voice echo for everyone who speaks with the exception of me. Somewhat annoying.
 
I'm not having any audio cracking issues, but I did have audio desynced at the end of Act 1. It was still playable however.
 
If anyone is using just your regular gaming headset or something similar, I found that raising the sample rate in the Sound Control Panel to 16 bit 48Hz worked for me! Hope it helps someone :)
 
Sound gets distorted over 96000Hz 32-bits. Though you probably wont tell any difference at all from 44000Hz 16-bit. I normally don't use audio effects at all, but I decided to mess around with Nahimic and during the first part of the game in the club/bar I it felt much more lively when I turned on the volume stabilizer. Seems to enhance those ambient voices.

Headphones I use DT 1990 Pro + Sennheiser GSX 1000, but find myself changing in-game volume sliders as some people seem to yell in my ear half the time...

Anyone have a preference for their sound sliders or do you just leave it at 100%?
 
I'm getting the crackling, I've changed to 44100hz and 48000hz, still no change. I get the crackling.

I use a third party app to push my mic and audio through. When I disable and just use the headphones from the sound settings, directional audio doesn't work with the headphones (with spatial sound turned on or off).
 
Hello there. I have some audio clipping which is very annoying. That clipping appears when any object making a sound, for example, ingame music, or when someone is talking or the sound of ventilation etc. Not cutscenes.

Results of tests:

•As you get closer to the object, the crackling volume increases.

•The more times you load the game, the stronger the clipping. At the same time, the basic sound itself / the main sound is not distorted. When I loaded the same save 3 times in a row, the clipping reached its maximum values in the number (frequency) of the clips themselves and their level of volume.

•If you load the game when you standing close to the source of loud sound it will cause the maximum level of clippings/clicks. At the same time when you load the game with far stay from source position then as you get closer to the source, it will cause the only medium level of clippings

•Once I have managed to get rid of it - restarting the game, but next time this method wasn't working.

HOW TO SOLVE IT

I simply increased the sample rate level in Windows sound preferences from 44.1 kHz to 48 kHz or to 96 kHz. It helped me) Cheers!


Windows 10, CP2077 Steam version
I have no Audio adjustments or so
I use only Realtek Audio driver 14.06.2017. 24bit 44.1khz
Tried different headphones, different levels of volume (by Windows mixer, CP2077 settings sound mixer)
Other games haven't that issue.


P.S. Damn! I just want to play a game!)
 
Last edited:
Hi CDPR,

I have two issues:

1. I have wireless headset sennheiser gsp 670. When I play Cyberpunk I have sound delays and "electrostatic noises".
When I change sound device to my speakers, everything is Okay
The issues with earphones only in this game. When I play other games and listening to music on my PC I don`t have this issues.
Tried to update drivers and connect with USB cable, did not helped
I tried other in game settings, didn't helped
Yesterday after game launch, the sound was good, the sound issues started today. My PC don't updated during this time

2. Language settings not saving after game exit. On each game launch I need to set it again
My settings: Voice: English; HUD and captions: Russian
On each launch the settings is revert to English on everything

Thanks
 

Attachments

  • DxDiag.txt
    96.3 KB · Views: 135
Top Bottom