Jobs Support Register

Graphicresolution 720p Bug fixed

+
#1
Graphicresolution 720p Bug fixed

Hallo People

First i want to say, my PC built/looks, how it came about (which I had the 720p bug), and how I came up with the solution.
This is a bad translated Version of my German Thread @ https://forums.cdprojektred.com/foru...0p-bug-gelöst






my PC-Specs:
CPU: AMD FX 6300 (leicht übertaktet)
Ram: 8 gbyte DDR3 Ram
Graphic Card: XFX ATI Radeon HD5870 (AMD Radeon) connected via HDMI
Sound: Asus Xonar STX
Monitor: Toshiba TV (1080i) as a replacement for broken full HD PC Monitor (my first Suspicion was, that it is TV bug or so ... no, it does not!)
Windows: Win 7 x64 Ultimate
the rest should not be so important.

So it's a bit older and slowly getting in the Years.
Newer drivers are hardly to get... (For Games, this PC is still pretty good and fast)
Actually, the specs do not play a big Role in the Appearance of the Bug,
because it hits Intel, AMD and nVidia alike (if you read the forums, and I had plenty of time to do so).

Ok,
When I first started Gwent, everything was great and the graphics were great to.
Played a bit and tried around.... all was fine, but then I wanted to go into the settings,
the Music was too loud compared to Voices and SFX.... barely clicked on it, HE WAS ALREADY THERE ... 720p BUG !!!

Well, what is the 720p bug?
Actually quite simple, you have a Monitor and Graphics Card that can represent more than 1280x 720 pixels (for example, 1920x1080).
If Quent has already given you such a better Picture (thanks to Auto-pre-settings ...) and you go to the Settings Menu, or restart the Game, and then suddenly everything looks slightly pixelated and blurry, then you have you most likely caught the 720p bug. Because your Game will be only displayed in 1280x720 from this Point on, and not as previously assumed in 1920x1080.
In the Settings Menu you get then not more than 1280x720 to choose.

Mhhh... i searched in the forums, a solution was found quickly (it is NOT YET THE SOLUTION).
Simply the Registry Entries of Qwent (CDProjektRed) deleted, then start Game (Graphics ok again, but Music still too loud).
So again in the Settings Menue... ( dung... Graphics broken again... ) ...
Ok... , So start Regedit again (as Admin), delete Entries...
Start the Game and Exit ... Regedit start and enter the Music-settings by hand (for me the value 5 fits)
Regedit Pfad: HKEY_CURRENT_USER\Software\CDProjektRED\Gwent
the Point MUSIC_h211975204 , the right value change it before the dott of 10 in X (5 or 4 or what you like).
But it will only be necessary if the Bug is persists and my solution does not help.
So, then everything was fine with me, Graphics fit and Music too! I just could not go into the Settings, otherwise 720p was back...
Now, I was able to play without Problems for 2 or 3 Patches and survive my first Season... (Rank 16 Yay) :)
A new Season and a new Patch (02.2018). Install, Quent startet.... SURPRISE.... 720p is back..... :facepalm:

Although my Monitor and Video Card can easily display in 1080p, and has done it so far,
this time, my old solution did not work out....
Nothing to do... changed always back to 720p once the Game has started, even in windowed Mode....
You could test that wonderfully and see in windowed Mode (set the Resolution high in the registry, to 1600x900),
then started the game and watched as the window became smaller by itself.
This worked in full Screen to, you could watch as the Resolution of the Bird changed from razorsharp to pixelated at startup.


Searched again in the Forums....
Only with nVidia Graphics Cards, there seems to be something like a solution ... Turn off scaling
mhhh, with Radeon from R2xx there seems to be something to do with downsampling (something does not exist in my old Catalyst Graphics Card driver)...
But it all has something to do with Scaling... Quent dont offer me Resolutions higher than 720p (1280x720)...
So I have everything, that I found in the Graphics Card driver and Windows .... everything that looks like scaling, have i turned off ...
I needed 2 days to search and solve....

TADA.... HEUREKA... THE FIX or SOLUTION ....:surprise:
Indeed,
Quent started and I get all Resolutions offered in the Settings Menue, all Resolutions which my TV-Monitor (Monitor replacement) can, up to 1080p.
Also the fine crooked intermediate Resolutions, if they are 16: 9 !!
(I would never expected that, just hoping that full HD works as before)

What did I do/search for ?

The settings in the Catalyst graphics driver should be as follows:
No Scaling (I know, pretty superficial, but I do not know all the terms in the newer drivers and my Catalyst is in german language)
go through every Menu Point and turns off everything that smells or looks like a scaling.
Features of Digital Flat Panel Monitors / GPU Scaling turned off (In addition, I still have the ITC-Processing turned off and found no visible difference)
Overscan off and set to Standard (which causes 0% scaling)
I do not have a newer graphics card with Oversampling, but apparently it helps to disable Oversampling/Downsampling.
Something that has little to do with Scaling, but still does not cause any problems, is SupersamplingAA (i have it experimentally on ... no problem so far).

For nVidia graphics cards, there are certainly the same functions, but with different names.
I Think, it should still work the same way as Radeons.

Windows also has Scaling:
Go to the Gwent folder where the game is located and right click on the Quent.exe ,
and on the Tab Page Compatibility deaktivate "Scaling at high DPI Values deaktivate" .
In Fact, there was a hook there by me (in Settings for all Users).
One might think that the hook deactivates the Scaling, but the Opposite is the case (the tick turns Scaling on, especially for higher resolution Monitors, 4k, etc).
In Windows 10, I read that there is a similar function on the Compatibility tab .... turn off, get out of hook/tip whatever ...
Theoretically, the hook would not work for me, since nothing happens until 1080p,
but since all the other games and programs do not have this hook (sure for sure, take it off ....), why would Quent need it?

For me, this Solution has helped.
I just do not understand, why Quent does not recognize the Screen Resolutions when scaling is on ???
Where does Quent read that out, if not in the registry ?
Normally, Scaling helps to avoid these Problems, not to create BUGS!
Keeping this in Mind, the Connection Problems that many People might have, be due to a similar cause
(Automatic some Optimization that would be better off, because Quent (Unity engine) misuses them)
But this is for other People, since i dont have this sort of Problem.... for now....

Another tip on the Edge, in Windows System Settings, there is also hidden a DPI Scaling, which is set normaly at 96 DPI (leave it at 100% = 96 DPI).
I assume that this Attitude, too, influences Quent!
In addition, many Programs play crazy, if you change the DPI (For Smartphones is a DPI Change much more useful)


I hope that helps you,
Best regards Maestrocool
 
Last edited:

Pwnder

Junior Member
#2
I have no such option on Nvidia platform.And about the scaling mine is greyed out..So how can I get my native resolution?
 
#3
Pwnder;n10474722 said:
I have no such option on Nvidia platform.And about the scaling mine is greyed out..So how can I get my native resolution?
You dont need native Resolution, every Resolution is possible and did not disturb Gwent.
the Problem is every Form of skaling, overscan, dpi-change, oversampling/downsampling and such
Read the Text..... think..think...think one moore, then search in Windows and nVidia Driver.
Im sure you will find something !