Jobs Support Register

[BUG] Ruined Inn, Skellige - Abandoned Site Icon Missing & Quest Issues

+
#1
[BUG] Ruined Inn, Skellige - Abandoned Site Icon Missing & Quest Issues

Issue: The Ruined Inn site located south east of Fyresdal is marked with and Undiscovered Location icon (two if you have the relevant gear quest) On clearing the Monster Nest and associated Harpies/ Ekhidna you get the Abandoned Location cutscene and it becomes populated even though there is no icon to identify it as an Abandoned Location.

Several interconnected issues being:

1. There is no Abandoned Location icon to indicate you can actually liberate the Ruined Inn village like elsewhere in the game.

2. The flying NPCs, Harpies and Ekhidna appear unable to attack in the centre of the village for some reason. Only when the player moves out some way.

3. One fly NPC Ekhidna paths further north nearer the burnt out inn and is easy to miss and as there is no icon, can result in the Abandoned Location completion if not killed. It also has problems attacking the player.

4. If the associated Scavenger Hunt: Bear School Gear quest is completed after the Abandoned Location is completed and NPCs spawned, on exiting the inn cellar all the NPCs spawned have despawned. NPCs will respawn on Meditating of reloading.

Platform/Version: PC Steam Patch 1.07.

Details: On entering Ruined Inn you see flying Harpies and Ekhidna and a Monster Nest icon appears. There is an associated issue that these flying NPCs seem unable to attack you near the signpost and only fly overhead screaming. It requires some movement further up the path until they are able to attack the player character. Or, some direction away from the centre.

Also, even having killed the nearby Harpies/ Ekhidna and destroy the Monster Nest, there is one flying NPC (Ekhidna) which seems to stay further up to the northern end and not obvious to the player that tends to try to attack when close to the burnt out inn. Once this last one is killed then the Abandoned Location cutscene occurs and only then.

This means many players will miss this event as it is not obvious what it required as the indicated Monster Nest is cleared already.

Finally, there is a further bug/ glitch that if you have the Scavenger Hunt: Bear School Gear quest (Ursine Steel Sword) and clear and loot the item in the inn cellar, on exiting all the NPCs that had spawned on completing the Abandoned Location quest despawn.

However, it seems that these NPCs are prone to despawning if leaving then re-entering the village centre. Meditating sees them return. Same with Herbalists availability.
 
Last edited:

TheFanom

User
#2
I have another Problem with this Abandoned Site.
I killed every monster (ghosts and harpies), destroyed the monster nest and even scanned a wide area around the ruined inn for any other monsters.
Nothing to find. Still the NPCs won't return to the Village.
Sometimes if I start/reload or try something else to fix this problem the ghosts return or I could even destroy the monster nest again (without any harpies or else being around).

Does anyone have the same problem or an idea how i can fix this?
(PS4-Version/Patch 1.10)

PS: I discovered another glitch while trying to fix this.
If I enter the house with the cage and the boat in it, there seems to be a crate or a chest under the boat i cannot loot.
When I accidentally climbed on the boat, I found out one can glitch through the house when you run in to the corner of the house whilst being on top of the boat.
 
Last edited:

lifeonerth

User
#3
I have the same problem, I came to the site, cleared all the sirens, destroyed the nest, killed the wraiths, and patrolled around a good area looking for any extra monsters that escaped notice, but there are none...not even underwater. I do have an icon that says "abandoned site," but now the people won't come back and I get no cutscene. I also picked up the Bear School diagram but it did not seem to affect anything else.

The abandoned site icon is still white, not greyed out, as if I have not killed the monsters. I am on Xbox One playing version 1.10. Argh, please fix! Thanks!
 
Last edited:

DXMG

User
#4
This spot is wierd... for me on 1.10 it goes like so:

Get there, people already there.

Kill sirens/nest/get scene where they return, even though they are already there.

once the scene ends, they are not there. lolwtf

Go kill wraiths/get Witcher gear diagram, now they are back!

leave and come back/meditate, etc, and they are gone again.

:thinking:
 
#6
I also have this problem, and unfortunately don't have a saved game from before going to the inn. Is there any fix?
 

Reaven

User
#7
I also have this problem, and unfortunately don't have a saved game from before going to the inn. Is there any fix?

This problem persists as of 11/28/2015. Playing on 1.11 just cleared the sirens, their monster nest, and the wraiths in the nearby cellar to no avail -- area does not repopulate with NPCs.
 

Merwanor

User
#8
I ran into this bug a while ago, it is not fixed yet it seems. I am running Patch 1.11. Now when I return to the area, two wraiths seem to spawn in the cellar every time and I could even destroy the siren nest again even though I already did it before. No sirens in the area though.
 

Tooms

User
#9
I had the same problem, still in 1.11. Cleared everything out, still says abandoned site. I submitted my savegame.

Edit: It appears to be one of the sirens that is a bit out of range to the north-northeast. If you blow up the nest while it's still flying around, it may disappear or get glitched underground or something. I re-did it, killing 4 sirens near the burned out inn, then going over to blow up the nest, and finally the ekidhna that spawns after you blow up the nest. This successfully repopulated the town. You don't need to kill the wraiths.
 
Last edited:

Skull_Kid

User
#11
Unfortunately the same issue here, playing v. 1.12 :-[

Since this was the first serious bug I ecountered after 120 hours or so of gameplay, I just kept playing. I was confident the sirens would simply reappear after some time...but no.
Really annoying for a completionist like me. Sadly my last save game is from about 20 hours ago.

Would be great if this could be fixed by a patch somehow. It's a pity...it's one of the greates games I've ever played and everything worked perfectly fine so far.
 
Last edited:

talleyrand

User
#14
I came back after more than a dozen or so hours after doing everything else there. (monster nest, quests) There isn't another monster besides the two wraiths that normally spawn there. Not sure if could be related, like a collision problem in the terrain, but every time I kill the wraiths their "loot" lands above ground. For the time being this place will remain white and not completed.

Bugs the hell out of me but not enough to go back more than 12 hours of gaming.
 
#15
On xbox one with version 1.12 on ng+ .......this worked on my normal playthrough but will not work on ng+ for some reason...the wraiths keep respawning on ng+ but didn't on regular play through. I have meditated, fast traveled out then back (used Vizima) still can't get the npc's to come back.
 
#17
I've killed all the sirens and ekidnas that are there (or at least show up. I have meditated, gone and completed other missions and I cannot get them to reinhabit the abandoned village....I have xbox one, no save files to upload.....I just went back again and the only thing that spawns are the wraiths...nothing else is there !!
 

G3sSi_89

User
#19
oh, thats the better thread for: Same Problem, killed all sirens, not people come back. Version 1.22, PS4
 

thwidra

User
#20
The problem is still there in V1.31 (PC). Can't clear the abandoned site, but killed all the monsters and destroyed the monster nest...