Erratic mouse on macOS Ventura (x64)

I have run the game (GOG purchased) multiple times on an older MacBooks without any issue.

Now I tried MacBook Pro 2019 (x64 Intel) with the latest macOS Ventura and the mouse is just erratic. Instead of being able to look around it randomly freezes or jumps. One moment I can only turn 1/4 circle to the left but full to the right, just to see the mouse to jump so the character is looking up into the sky. Next moment, left turn is fine, but right can only go 1/3 of the circle. Crazy, and sadly, unplayable... I tried to tweak camera sensitivity as well as display resolution, but none of that makes any difference. Needless to say that outside fof the game, even in the game menu, the mouse behaves as it should.

Anyone experienced the same? Any way to fix it? It's a shame, I really hoped to play once more...


Upvote 0
I have tried wireless mouse (BT), wired mouse (USB) and built-in trackpad. I have tried trackpad disabled when using mouse. I have tried different camera sensitivity as well as screen resolutions. I have killed all other running apps and non-essential background jobs and services. Unfortunately, it continues to behave erratically regardless the pointer device and/or the settings. In fact, wired mouse doesn't even register clicks when in the game itself (works OK in the menu).

So it is likely something deeper, between the game and OS, effectively out of user's control. Without an patch, the new(er) macOS is effectively unsupported. I cannot find any way to open an official technical support ticket.
Last edited:
Top Bottom