Jobs Support Register

Game keeps crashing to desktop randomly [ Finally found a solution ]

+

katori142

User
#1
Update: Okay so i found a fix and it sounds so weird. If you think reinstalling game is enough, or even Reinstalling the whole OS , clean every driver installed on your PC is enough for a fresh new game installation to get rid of all issue, then you are wrong at least for this game. This game somehow can keep your config file ( or maybe some old file ? ) perfectly safe in somewhere i cant even imagine and know. i did clean the whole PC to ensure nothing left from my PC before reinstalling my game 3 times but the issue still occurs. Ridiculous right?. yesterday i was so despressed and i DISABLED STEAM CLOUD FOR THIS GAME then deleted the game folder, delete all file in documents/thewitcher 3 except save file and then redownloaded it one more time. this morning, i boot into game and the game tells me something about " reseted to default" and informs me about 2 big expansions HoS and BaW like the first time i started playing this game back to 1 moth ago. i had tried reinstalling this games 3 times in the past but this time is the first time i see the game informs me about "game reseted to default" thing. i ve tested the game at the same crashing place 40 times and no random crash so far. So happy. Turnout this shit use steamcloud to keep some crap file beside save files to restore back on my pc everytime i reinstall game ( or even reinstall my OS) Hope this help others who is still facing this ridiculouly painful issue.

....................................................................................

i bought this game 1 month ago. and for the first 3 weeks i have zero crash at all. game was installed on my HDD and the OS was in this HDD also. 1 week before i plugged in my new 860 evo SSD and then move my game folder to SSD. since this time i started facing random crash to desktop (CTD) it happens when loading save, when casting sign, when hitting E to talk to NPC/ starting an intro or whatever, it is totally random. i have spent 3 days to google and see that there are plenty of user that having the same issue as mine. i ve tried many many solution found on network but no luck at the end. what i did:
verify game cache, updat driver, reinstall games. lower graphics setting and even reinstalled my whole PC , and put the OS into my SSD but the same issue still occur. there is nothing wrong with my PC or driver or software component because the game was working perfectly in the past ( first 3 weeks , and i had spent 150 hours within this 3 weeks ) issue only occurs after my pc having new SSD installed. but it is not SSD fault right ? because everything is working perfect and fast , OS, other program, other game runs smoothly on my SSD with out any issue no Blue screen whatsoever. only this wicheer 3 keeps crashing at random moment which is driving crazy. it just crash to desktop with out any message or error hint it looks like i use alt f4 to kill the game. the crash log related to EXCEPTION_ACCESS_VIOLATION (3221225477). yes always this ACCESS VIOLATION with diffirent Error reading location and only the GOD knows what in the world it means.
I have tried every single way on google to fix this but no luck and now i am so depressed and sad. Because i love this game so much but can't stand this random crash at all even though it is not too frequentlly like every 5-10 mins but still drive me crazy.
my spec : i7 7700 gtx 1070ti 16 gb ram, 1TB HDD and 500 GB SSD samsung evo. and i dont use any mod.
below is top info of my crash log file. i see this crap ACCESS VIOLATION everywhere on google.

Crash reason: EXCEPTION_ACCESS_VIOLATION (3221225477), Error reading location 0x00000090

Crashed Thread:

Thread ID: 3252

callstack:
Scaleform::Render::Matrix4x4<float>::SetIdentity() + 0xa65ed9 - <Unknown File>(0)
Scaleform::Render::Matrix4x4<float>::SetIdentity() + 0xa64cec - <Unknown File>(0)
Scaleform::Render::Matrix4x4<float>::SetIdentity() + 0xa6491b - <Unknown File>(0)
Scaleform::Render::Matrix2x4<float>::prepend() + 0x1fb3e3 - <Unknown File>(0)
Scaleform::Render::Matrix2x4<float>::prepend() + 0x1fdfe9 - <Unknown File>(0)
..........
can anyone help me to fix this issue and is anyone else thats till having this issue please tell me :((( why in the world this issue come to me, to us from nowhere in 2018.
Please help me thank you everyone who reads this and drop a word :(((((((
 
Last edited:

devivre

Moderator
#2
Any mods installed?

Just moving game files to a different drive while the old drive is still running is always a bit risky. Uninstalling the game first (when it‘s still on the old drive) and reinstalling the game on the new one can be the safer way to go.

Aside from that, I don‘t know if it‘s related but you could try rolling back to an older version of the NVIDIA driver (for example 399).

CDPR support can be reached here: https://en.cdprojektred.com/contact-support/ Keep in mind, they might take a while to reply as there is currently a lot going on with Gwent.
 

katori142

User
#3
Any mods installed?

Just moving game files to a different drive while the old drive is still running is always a bit risky. Uninstalling the game first (when it‘s still on the old drive) and reinstalling the game on the new one can be the safer way to go.

Aside from that, I don‘t know if it‘s related but you could try rolling back to an older version of the NVIDIA driver (for example 399).

CDPR support can be reached here: https://en.cdprojektred.com/contact-support/ Keep in mind, they might take a while to reply as there is currently a lot going on with Gwent.
Thank you. there was no mod installed and i did reinstall the game, even reinstalled the whole PC with fresh new OS in my new SSD, and looks like cancer, this issue still occurs for god- know reason :((. Driver version didnt help. i 've been trying plenty of version from 391.xx to the lastest one.
Post automatically merged:

I found a solution. jesus christ who would imagine the game is broken by this way..
 
Last edited: