Performance issues with Witcher 3 ver 4.0

+
After several hours of playing i am still noticing frame drops in fights for example with wolfs under heavy rain and wind conditions by night.

For me this "feels" like a buffer overrun, i cant discribe in words...

You stay on a dirt road, 75 FPS are stable, wind, rain and night, wolfs appear and you start the fight...

For some seconds the fight is stable with 75 fps, but then the "frame drops" start while the fight...

When the fight is finished, it takes even more seconds after seeing the wolf bodies on the ground, frame rate is still suffering... and takes some more seconds to get stable again.

Whatever is impacting fights concerning the frame rate, it is still not on a good level.

Still room for improvement.
 
I'm glad the hotfix has helped many people - but it looks like I'm still up the river - the game keeps crashing whenever I try to load a save (granted an old save from my first playthrough) or even start a new game.

When starting a new game I can see the intro movie but as soon as it tries to load into game - crash.

I'm not even trying to play at the highest settings - I even tried on "LOW" with DX11 - just to see if I can get it running.

Pretty disappointed - I just hope an actual patch is released that solves this.

Is anyone else in this boat?
 
Last edited:
After the last minor patch, performance has dropped drastically. While I was getting 70fps at the highest settings, now (45 50fps) I have no pleasure in gaming.
 
Well, I could play the game with RTX 3070 mobile and AMD 5800H with RT ON and some tweaks in settings (mic of high and ultra) but the fps drops over time... I start at 35-45 fps and then it slowly drops to 15-20 fps and it's unplayable. The GPU power usage drops in a similar manner. It's like the game is no longer recognised as full screen as I got the same fps as when I use borderless window in display options... I seen many ppl having the same problem of performance dropping over time and this is really a very bad issue imho...
 
Can confirm that I had comparable FPS using a 3090 and a 4090. I just got my 4090 and popped it in with identical settings I used for the 3090. 4K DLSS2 Quality everything maxed. It is CPU bound for sure and really taxes a limited amount of cores. Popping DLSS 3 on which doesn't need the CPU to generate extra frames solves the performance issue albeit with more latency than is typical for having in excess of 100fps. I am not a guy who needs all my games to be 200fps. I'm happy staying over at least 60fps stable in 4K and elated when I can get over 100. The 4090 has so much juice it should be able to provide for me without having to resort to DLSS3 which has some shortcomings. I am glad I have the option to use it but was hoping to be able to run this game at 60FPS stable with just DLSS2 Quality. Nope.

I have a threadripper 3960x. I know it isn't the best for gaming out there but it has always been enough to not be a bottleneck for me in 4K since GPUs are almost always the bottleneck in 4K gaming. In this case however it is the CPU.
 
Problem with DLSS 2 on RTX 30xx is that it completely doesn't work. There is no any internal image scaling and this is why there is no any speed benefits while using it. Problem may be with Nvidia driver which locked this feature to prefer RT 40xx series with DLSS 3 instead.

Hm, but that would be... so evil of NVIDIA... but now that you say that... I somehow understand why I get double the FPS on my 3080 when I am using TAUU instead of Ultra performance (!!!) DLSS...
 
Can confirm that I had comparable FPS using a 3090 and a 4090. I just got my 4090 and popped it in with identical settings I used for the 3090. 4K DLSS2 Quality everything maxed. It is CPU bound for sure and really taxes a limited amount of cores. Popping DLSS 3 on which doesn't need the CPU to generate extra frames solves the performance issue albeit with more latency than is typical for having in excess of 100fps. I am not a guy who needs all my games to be 200fps. I'm happy staying over at least 60fps stable in 4K and elated when I can get over 100. The 4090 has so much juice it should be able to provide for me without having to resort to DLSS3 which has some shortcomings. I am glad I have the option to use it but was hoping to be able to run this game at 60FPS stable with just DLSS2 Quality. Nope.

I have a threadripper 3960x. I know it isn't the best for gaming out there but it has always been enough to not be a bottleneck for me in 4K since GPUs are almost always the bottleneck in 4K gaming. In this case however it is the CPU.

This is exactly what I am seeing. With lower texture detail than CP2077, with similar or lower crowd count, and with similar RT settings, why is the performance half? How horribly did CDPR optimize the CPU usage that GPU is barely being used?

Is this a trend and a pattern with their every release/update(/downgrade)?

CDPR deserves all the negative press coming to them. In past 2 years, they just fail to deliver time and time again. Execution and quality is just not there.

It took them 2 years after CP2077 release to make it playable. I was hoping that they learned something from that experience. Apparently not...

People talk about horrible console ports. How about a terrible PC to PC port?
 
I noticed in certain scenarios where npcs stays together, the frame rate just drops massively, for example - the King Bran's funeral. i ran DX11 with ultra setting with stable 120fps for the most part of the game, but that scene literally drags my fps to less than 30....and it only happens when I face the crowd. This is definitly where optimaztion goes wrong.
 
My issues include Geralt attacking in the wrong direction (toward nothing, despite enemy being nearby), constantly using the wrong mousewheel inventory (draws torch when I select bombs) and sometimes just not responding to the attack button at all.
 
My CPU Usage drops to 10 percent after about 20min of playing.
I have an RX 6900XT and a Ryzen 7 3800X.
Every other game with raytracing plays relatively well.
 
After the Dec 22, 2022 hotfix, performance is still terrible with ray-tracing enabled. I go from 100+ FPS on max settings, to 40 when I enable ray-tracing.
 
Spec:
i5-12600
RTX 3070 TI

Not sure if this was already posted here - if so, I apologize in advance.

The VRam consumption between DirectX11 and DX12 is more than double.
I believe that this is what causes the issue where you boot up the game in Dx12 and can play fine for an hour or so, but then, the frame-time spikes and lags, and it becomes unplayable.
Ultra+ settings in Dx11 is consuming ~4GB VRam (90 - 100fps)
High settings with RT GI and AO, is ~7.6 VRam (50 - 60fps at start / unplayable after ~1h)

With an 8GB VRam limit, you can see where that becomes an issue.
 
If I load multiple saves in the game (not in the menu), it becomes unplayable after the third.
And I have a friend who has a 13900k with a 4090 RTX and even he has stuttering in Novigrad during the day (frame generation enabled/disabled. DirectX 12 is supposed to distribute the load more evenly across all cores, but that's not the case.
 
Why My witcher 3 DX11 version having graphical issue like the surface show's Weird colors all over the place?
What is the solution if anybody can help.
 

Attachments

  • Screenshot_20230115_024622.png
    Screenshot_20230115_024622.png
    4.6 MB · Views: 62
  • Screenshot_20230115_031916.png
    Screenshot_20230115_031916.png
    4.2 MB · Views: 62
Last edited:
Why My witcher 3 DX11 version having graphical issue like the surface show's Weird colors all over the place?
What is the solution if anybody can help.
Hard to say, but :
Do you use, or used mods ?
You can try to verify the game files.
Maybe try to clean install your drivers.
NVIDIA
I. Download the latest drivers using the following link: https://www.nvidia.com/Download/index.aspx?lang=en-us
II. Download Display Driver Uninstaller and run it to remove previous versions of drivers.
III. Clean install drivers that you've downloaded in step 1.
AMD
I. Uninstall your graphics drivers using the AMD Cleanup Utility software.
II. Download and clean install the latest drivers from here: https://www.amd.com/en/support
 
Hard to say, but :
Do you use, or used mods ?
You can try to verify the game files.
Maybe try to clean install your drivers.
No i don't use mods.
tried with clean driver installation still not fixed
 
No i don't use mods.
tried with clean driver installation still not fixed
Probably you still instaling game on same folder, even if you uninstalled W3 the remaining mods files, which you may have already forgotten, won't be deleted. Install W3 in a new directory or make sure the entire game installation folder has been deleted.

Even after reinstalling drivers (best way to use DDU to do it) you have still this issue, then this graphic artefacts my be couse by broken GPU.
 
Top Bottom