RT low FPS

Hi there!

I am really confused. I just tested the Witcher 3 with a few settings in 1440p.

With UBER+, DLSS balanced and RT off I have over 100 FPS. When I turn on RT it is below 40 FPS. When I set every option to low and off but still keep RT on, I get 50 FPS.
It's really weird for me. Is a RT out of reach for ppl who don't have a new geforce?

My configuration: R7 5800X, RTX 3070TI. Drivers updated. My thoughts are that, this is done to buy the latest graphics card, I mean 40XX series. These is SAD.

I hope we will get a small update for RT balance. I have seen a lot of comments about RT and poor FPS.
Well, RT is often a huge performance killer. But 40-50 FPS doesn't seem bad. I don't think it's intentional. For example, with CP2077 RT was demanding long before the 4000 series existed. Besides, the 40xx still needs a very good CPU to keep up with it, so it would not be enough on its own.

A better CPU might be a cheaper solution to boost the performance. But I really don't know, I have a similar setup like yours myself and I also prefer to avoid RT in general (or I use a regular HD resolution).
to be honest , even we know RT features 're heavy taxing both cpu/gpu , atm Ray trracing 're not well optimized on this witch 3 next gen update : its broken . the other difference between cyberpunk 2077 RT and witcher 3 RT . on cyberpunk all level RT 'quite well managed , but atm on witcher 3 its a feeling RT features set on basis , none or full , there's no intermediate level RT on PC version .

witcher 3 even with those many bugs at launch , its one of AAA game well know to be really optmized on pC for all scope config , not like the disaster of this update :)

when people prefer rollback on first day on 1.32 build beta , may be there's somothing wrong . its good to advertasing 4090 rtx , but 80% player running on 2xxx or 3xxxx serie rtx or equivalent . hope CDPR react quickly to fix that
Well, RT is often a huge performance killer. But 40-50 FPS doesn't seem bad. I don't think it's intentional. For example, with CP2077 RT was demanding long before the 4000 series existed. Besides, the 40xx still needs a very good CPU to keep up with it, so it would not be enough on its own.

A better CPU might be a cheaper solution to boost the performance. But I really don't know, I have a similar setup like yours myself and I also prefer to avoid RT in general (or I use a regular HD resolution).
I played a lot, and I had a fps drop below 30 FPS and even 25 FPS. On medium setings with RT. I bought this graphics card to use the RT settings. For me it looks like a joke, they had a much time to prepare it right, they failed again.
DLSS is not really working atm neither, at least for me.

I get a small uptick from TAAU to DLSS quality, about 8-10%, then no improvement going to balance, performance or ultra-performance.

Anyone else not getting much from DLSS with RT turned OFF?
I also noticed that ray tracing doesn't work for interiors, which makes the poor performance even more confusing. If it were full raytraced lighting like cyberpunk, I'd be at least a little bit more understanding (even though interiors are what needed the RT lighting the most, and would have been improved a crazy amount with it)
Also seems that hair works hair doesn't receive raytraced lighting very well. Seems the RT was added at a last minute notice, I guess. It's not very well done at all.
Update ships with DLSS 2.4.0, so something must be broken. Got much better FPS (90+) with DLSS 2.5.0 from TPU.
Hello everyone! I to am having horrible performance with DX12 on a beefy machine (specs below) with update 4.0 so I am coming over from Reddit with a full detailed post on my test/theories/full breakdown so here we go.

TLDR: The games DX12 implementation is 100% broken and causing awful performance/scaling along with stutters and graphical bugs. The game also seems to only utilize 2 CPU cores which is causing every GPU to be starved (with the exception of 40 series cards DLSS 3.0 and some 4k setups) no matter what you do. DX11 implementation works much better but you lose DLSS/FSR/RTX the selling points of the update. Lastly Alex from Digital Foundry is going to do a video and has already tweeted the patch defiantly has issues/CPU being a problem.
I also linked some tweets/articles/videos at the bottom confirming issues and proving it is not just ranting or a handful of people.

My original Reddit post here

So to begin I believe I have narrowed down what the two biggest issues are.

First: the game seems to only use two of my 5900X's 12 CPU cores (Cyberpunk also originally had this issue but to a lesser degree.) I’ve never seen the games CPU usage above 6% and I commonly see it at 1-2% usage. What the underutilized CPU means is that the game is starving our GPUs causing them to also be underutilized. For GPU I’ve seen as low as 45% I’ve seen as high as 85% , but nothing ever close to 100% unless playing on DX11. So in other words the games poor CPU optimizations is causing our beefy GPUs to not be fully used killing our performance while we have headroom left on our hardware.

This is not just a me issue several reports now claiming the same thing and I’ve done the testing and posted the screenshot in prior linked Reddit post above so I believe this is what’s likely happening.

Secondly: the games DX12 implementation is straight borked on PC and I’m even reading reports of the same thing for next gen Xbox as it also uses DX12. What this is doing is causing horrible scaling of settings, lower than expected performance, stutters, and possibly the graphical glitches/crashing.

How did I come to this theoretical conclusion?

To start my rig: Asus Crosshair VIII X570 (latest BIOS 4201) with a Ryzen 9 5900x slight OC to 4.95ghz, 360 AIO cooler, Asus Strix Rog RTX 3080 with slight factory OC, 32gb 3200mhz ram, and game installed to a 1TB Samsung 970 Evo NVME also latest Nvidia drivers (527.56) and latest version of Windows 11 (Windows 11 Home Version 22H2 Installed on 10/‎19/‎2022 OS build 22621.963 Windows Feature Experience Pack 1000.22638.1000.0) Note this install of Windows 11 is less than 2 months old and was a full fresh install not an upgrade from previous Windows 10 install and game is fresh installed not priorly modded due to my recent wipe moving to Windows 11. Also hardware accelerated GPU scheduling is on.

Now background info I run all my games more than fine (to include reasonable RTX) and could not complain but for the sake of keeping it short we’ll do OG 1.32 Witcher 3 and Cyberpunk 2077 this same rig did 1440p Max at 140+fps in Witcher 3 we are talking hair works and everything.
Cyberpunk 2077 all settings maxed minus the two psycho options and all RTX on at 1440p DLSS balanced locked 60 from day one to most recent patch.

Ok next gen Witcher 3 so to break this one down if I do all lowest settings possible on DX12 1440p DLSS performance I get 80-100ishfps or less. Again going back to my background info this same machine could do 1440p maxed at 140+ fps easy with 1.32 but now all lowest settings 1440p DLSS performance or TAAU with resolution scaling I get 80-100fps.....

I CANNOT make this up I am seriously somehow getting ALOT less fps at all low with DX12 compared to OG maxed 1.32 with the same rig....
If I turn on all RTX with all other settings low DLSS Ultra Performance I get 35-50FPS!
Turn it to all lowest settings 1440p DLSS Ultra performance with only RTGI I get around 42-55fps!
MAX game out with 1440p DLSS quality 32-40fps! Try to do anything to gain 60fps on anything RTX I can’t get it to.
Try to get 60fps on no RTX but ultra-ultra+ can’t get it to basically its all medium to low now no RTX and DLSS performance to net 60-75fps with less than 60fps 1% lows and insane input delay anything else I try gets me under 60 to as low as 32 when running maxed on my MONSTER (only 1.78% of 30+ million steam users have a RTX 3080) rig the same rig that runs Cyberpunk 2077 Ultra with RTX 1440p DLSS balanced and gets locked 60fps make it make sense please!

Now we can prove it’s bad DX12 by switching to DX11 and max it out obviously there is no DLSS or RTX but max so new ultra+ and TAAU no scaling at native 1440p I am now getting 100-110sh fps still not as much as maxed 1.32 but remember ultra+ settings and new screen space reflections and TAAU UHD texture etc.

This FPS on DX11 makes more sense than all low no RTX DX12 getting only up to 100fps but hovering around 80-90........ If you match the games settings as close as possible to OG 1.32 on DX11 you get almost the same performance (probably around a 10-15% loss) despite the higher quality graphics settings that cant be matched. I was getting around 110-135ishfps so not as much as OG 1.32 but close enough and the scaling is working and this all makes sense.

So DX12 is borked. If you scale all the way to low you get a lot less fps than max DX11 and max OG 1.32 but max out DX12 and game is unplayable getting half the FPS as Cyberpunk 2077 maxed.....

Lastly on performance game refuses to utilize the GPU and CPU in full. Maxed DX12 with DLSS quality I see 80-85% usage, maxed DX12 with DLSS ultra performance 50-55ish% usage, maxed DX12 with TAAU 45-50ish% usage, lowest settings DX12 40-45% usage. All meanwhile performance was at its worst 30ish fps and at its best 100fps but I still had hardware left to use....?

DX11 no issues 99-100% usage game scales fps scales just DX12.

At this point I am just waiting for Alex from Digital Foundry’s full tech review to highlight and confirm or elaborate on my findings. I’ve learned most of what I know from him over the years and he’s the wizard when it comes to stuff like this.
The devs already tweeted they are investigating the issues so the game will be shelved for me until a patch is released.

For clarification I’m not mad I’m just sad. I was really looking forward to this, it’s my favorite game of all time and I have a beefy enough machine that I should be able to do mostly maxed 1440p DLSS balanced 60 like Cyberpunk…..

Thank you all for the read and for those that aren’t having issues and enjoying the game good luck on the path!
Sources and good reads:
Alex’s tweet (From Digital Foundry):
John’s tweet (From Digital Foundry):
CDPR tweet:
Marcin’s tweet (CDPR Global Community manager):

Videos and 3rd party benchmarks show exactly what I am saying here:


The Witcher 3 Next Gen Update | Ultra+ Setting With RTX Ultra | 3080Ti Benchmark! 1080p

The Witcher 3:Wild Hunt Next-Gen is Still Performance issues and Optimization.● SETUP● ● CPU: AMD Ryzen 9 5900X 3.7GH● GPU: NVIDIA GeForce RTX 3080 Ti 12GB● ...



RTX 3080 | THE WITCHER 3 Next Gen Update | Ray Tracing | DLSS | Ultra+

If you like this RTX 3080 | THE WITCHER 3 Next Gen Update Benchmark / gameplay content, make sure to like and subscribe Full Specs: https://linktr.ee/specsga...



The Witcher 3’s next-gen PC update is disappointing

The Witcher 3’s long awaited next-gen update has arrived for PC and its effect on the game is pretty disappointing. Not only does the addition of ray tracing...


Reports of issues:
For me, DLSS actually lowers the fps that I am getting in game. Very stuttering at times, maybe 20-45 fps in Toussaint average. Frames actually drop 5-10 with DLSS turned on. Bizarre. Game looks great, but it was much more playable before with the 50+ mods I had installed. Something is definitely off here....

RTX 3080 and AMD 5900x at 4K, Ultra to Ultra+ RT settings. Fresh game install no mods and clean install (DDU) of latest NVIDIA drivers.
Raytracing needs allot of polishing up to do.

ALL platforms Xbox, Ps, PC need a patch as they are experiencing horrible visual and performance issues
Every time i play i enter nvidia experience and reset to recommended settings. then i load my save and manually turn on RTX global illumination. works well with no crashes. but bad performance still.

i have 16gb ram and geforce 3070. Only about 60fps. 1440 resolution.

Top Bottom