[TW1][mod] Scabbard Mod ver 1.04

[TW1][mod] Scabbard Mod ver 1.04

One of the most long-awaited mods restores the highly desired scabbards. This mod adds 17 scabbard models to all swords. Additionally, a new sword with its unique model have been introduced to the game.

In a certain phase of the game creation scabbards were put in by developers. One of the main reasons why they couldn’t be found in the final version of the game is the rare but unavoidable clipping of a sword with its scabbard. Geralt’s animations don’t provide the possibility of avoiding it. Please take it into account when playing this mod.

Mod offers:
  • 17 scabbard models,
  • a completely new sword model.

Supported languages: English, Polish.

Scabbard Mod v1.04 Changelog

Download link:
I had to do a search to find out what a Scabbard was...From Wikipedia it says “A scabbard is a sheath for holding a sword”Looks good will try this out in a few days, thank you.
oh boy... got used to get whatever I want whenever I want, since I got to the game so long after everyone else... and now I'll have to wait for a full week :dead:looking forward though, good joob :beer:any chance of Aerondight getting a new model, different than common silver swords?
I downloaded this from moddb:http://www.moddb.com/mods/scabbard-modIt's bugged out pretty badly, makes the witchers turn into bug spiky balls with legs, screenshot attached.
The mod was released 19th december but I haven't announced it because I hoped to quickly fix few minor bugs before Christmas. Unfortunately Christmas which supposed to be a time of peace and rest appeared to be exactly the opposite. There was no time for myself and no time for modding.
dohclude said:
I downloaded this from moddb:http://www.moddb.com/mods/scabbard-modIt's bugged out pretty badly, makes the witchers turn into bug spiky balls with legs, screenshot attached.
You can see screenshots from the game with Scabbard Mod in the first post. No such bug appeared during excessive testing period. Are you sure you have The Witcher patched to 1.4?
I'm sorry. I'd fix this bug but I'm unable to reproduce it. It doesn't occur on my computer and no tester nor player reported it before.Maybe you could give more details that will help to indentify the cause of this bug.
Here's my PC specs if it will help in any way:Intel Core2Duo E7200 CPU4Gigs RAMNvidia Geforce 9600GTRunning Windows 7 Ultimate x64I've played multiple other games recently like Borderlands, Oblivion, STALKER, Dragon Age: Origins, etc. I haven't had any other problems with any other games that would lead me to believe that it's a graphics card issue. I've tried lowering the graphics settings in the game also. If I install the mod I get the glitch If I uninstall it, everything works fine again. I've tried installing the Flash mod and then selecting the "With Flash" option during installation and I still get the glitch.
I think I figured out the problem. I was using the latest drivers for my Nvidia graphics card (195.62). I uninstalled them and installed an older driver (186.18) which seems to have gotten rid of the glitch. I was having some similar graphics problem later on in the game in Chapter 3 even without the mod installed and so far the older nvidia drivers has solved this. I will let you know if the problem comes back at any point. By the way, great job on the scabbards. Looks way better than having your sword magically stick to your back. lol. :)
Thank you for feedback. I'll include this information about possible driver problems in various topics on forum. If it's breaking the game with and without mods then it's rather serious problem.
it's definitely the driver causing this. I tried re-installing 195.62 again and the problems returned. I tried another older one 187.66 and it went away again. The problem in the screenshot i posted only happen with the scabbard mod on 195.62, but that version also causes similar graphical glitches in chapter 3 as well as other glitches like menu graphics missing and a whole bunch of other stuff.
I installed it and it looked great. The only drawback was that Geralt had an empty sheath for the third sword dangling on the side even if he wasn't wearing one.
I noticed that too, and it was still there if you had an axe equipped also. looks kind of weird with a scabbard sticking out of the top of the axe.
It's one of the minor bugs which need to be fixed. It's minor because dropping the sword and picking it up fix the problem.Which sword is it?
Öhm, that's the problem: Geralt has no sword (apart from the 2 on his back) - only an empty sheath. I guess its the one for the standard temerian sword.
That's what I mean. Drop the steel sword from his back and all sword sheaths will disappear. When you take it back again the problem will fix itself.
Ok, I reinstalled the mod. Geralt has the silver sword and Harvall on his back and the side scabbard was glued to his foot this time. I dropped Harvall and the spare sheath disappeared. Fine.But I had to uninstall the mod again as it rendered the game unplayably slow. I don't have a programm to check FPS but I guess it was around 5 to 10 while it runs smooth without the mod (Chapter 2). My CPU (Intel E6300 1.86 MHz, Intel board - no OC possible) seems far too slow for this. :(
From mod's readme and general description:
known bugs:- In rare cases, the same scabbard on the same character, once lie properly on the sword, other time it's positioned incorrectly. The reason why this happens is unknown. It's the same scabbard, the same NPC, same files, same settings but the game somehow manage to break it.- Scabbard might lower game's performance in resource hungry areas. That's because with additional scabbard models the game is reaching engine' limitations.- Scabbards might be seen in camera during dialogues when Geralt is not on screen.- In rare cases scabbard might appear on the ground. If that happens just reequip the sword or change sword slot in inventory.
I suggest uninstalling texture mods.
Top Bottom