Jobs Support Register

"Card Collector" Achievement not popping / Collect 'Em All Quest not completing

"Card Collector" Achievement not popping / Collect 'Em All Quest not completing

So I've been waiting for patch 1.07 for Xbox One to complete my Gwent card collection: Zoltan Chivay was the final card I needed.

After checking the patch notes and seeing it patched in so it will always appear at Hanged Man's Tree, I loaded up my save (in front of Hanged Man's Tree), looted Zoltan Chivay and... nothing (except telling me I've got a Gwent card, as if this were the tutorial message). The quest "Collect 'Em All" is still not complete, and the achievement will not pop. I've tried loading the save again, fast travelling to another spot in Velen, then riding back to Hanged Man's Tree and looting again to no avail; tried a second time with meditation.

I've used multiple checklists online to check my collection, there are definitely no more cards remaining for me... is it possible this achievement is bugged and won't pop if this patched-in card is the last I collected?

As much as I enjoyed Gwent, I wanted my second playthrough to be solely focussed on beating Death March...

---------- Updated at 01:05 AM ----------

Further to this, I just tried reloading the save, then fast-travelling to Skellige and back (thinking I might need to reload all of Velen): now the Hanged Man's Tree only has the "Unfinished Book" and no Zoltan card... so I guess we're back to the original problem, 1.07 didn't fix this issue at all?
Hey guy! I've got a similar problem/bug. I just completed my gwent collection after patching the game (and getting 3 or 4 last cards). But the achievement doesn't pop and the quest isn't completed! When I beat new oponents of gwent game, they don't give me more cards. I checked the list on my The Witcher 3's guide and I saw that I have ALL CARDS but one... A Nekker (I've got 2/3 Nekker's cards). I think it's the Nekker who can be got by the Lambert's secondary mission.
Is that the reason why I don't get the achivement? I read that the three Nekker's cards aren't neccesary to unlock the achievement...
And I want the same: playing my second playthrough focusing the campaing for the last achievement.
Help pls!
PD: I'm sorry if the post has some fails... English isn't my mother language.
PD2: This problem/bug is in PS4 with the 1.07 patch.
Last edited:
I'm also having the same Issue, after patching and grabbing the zoltan card at hangman's tree the trophy didn't pop. I spent the past couple hours going over checklists multiple times. I know for fact I have every single card (Including duplicates), and yet the trophy is not popping :(
Last edited:
Not alone guys same here on ps4. Serious frustration after patiently waiting for this patch as this will be my first platinum trophy. Looks like waiting for another patch
Same problem here. However I didn't need the zoltan card. It just happened that tonight I went to the last merchant and got the last cards I needed. Very disappointed that the trophy won't pop and quest won't compete. Spent two hours going over lists just as others have and I have all the cards. It seems that the patch broke the whole trophy. That's just disheartening too considering how long I was looking forward to this patch going live. Now I wish it hadn't.
Yep, same for me. Im on Xbox One and I checked the checklist multiple times. I have all cards, still the quest doesnt complete. Oh well, then we wait for 2016 for the next patch to come.
I had to make an account for the sole purpose to post in this thread. I don't want CD Projekt Red seeing this thread and thinking it only affects people who got the Zoltan Chivay Gwent card post 1.07.

For me, on PS4, I had every card except for the cards won in the quest "Gwent: High Stakes". I got around to finally completing Gwent: High Stakes after patch 1.07 went live and my game did not register "Collect Em All" as complete nor did it award me the trophy for collecting every gwent card in the game.

For further details, yes, I do have every Gwent card after completing Gwent: High Stakes. I used a checklist and furthermore this is on my second playthrough where I made sure I got the Zoltan card during the tutorial and was able to buy the Gwent cards off of the bugged Claywitch merchant.
Ha just posted about this problem although I actually have the Zoltan card and won it at white orchard, 1.07 COMPLETLY BROKE the COLLECT EM' ALL ACHIEVEMENT I too have looked at the guides and have every card but nothing, no acknowledgement for over 100 games on gwent.
Same here on ps4. Zoltan was the last card I needed. When I picked up the card from hangmans tree I was expecting the trophy to unlock...but nothing happened. Reloaded from multiple saves. Still nothing. Like all of you I've checked my deck multiple times. I have every single card. Looks like the quest is completely glitched now. Ha I think I'm destined to never platinum this game. I'm interested to know if the trophy has unlocked for anyone since the 1.07 patch.
Same here. Trophy won't pop up. Zoltan Chivay was the only card missing. Got it from Hanged Man's Tree and..................... nothing.

Very sad.
I have got the zoltan card since the beginning (achieved it in white orchard) but wanted to catch up my only missing gwent card (wyvern) today after installing patch 1.07... I got my missing card from a blacksmith and was happily expecting the card collector trophy to pop up. but nothing happened, no matter how often I reloaded my last savegame to repeat this.
so in my conclusion this issue does not only belong to the zoltan card but to a more general problem of sync between the two patch numbers. I am really disappointed right now and wonder if cd projekt red will immediately patch this or if we'll have to restart the whole game to get platinum...
Bei mir das selbe Problem. Habe alle karten gesammelt und keine Trophy erhalten. Hoffentlich wird das schnellstmöglich gefixt
same for me on xbox one ive had the zoltan card the entire game. I was collecting cards and before i got to the last merchant i needed the 1.07 update automatically started downloading and then after it installed when i picked up the last few cards i got no achievement , what crappy timing :(
First I was waiting for the Claywich Merchant fix so I could buy those final cards. Still not fixed in 1.07.

Now I read this and saw the achievement/trophy is broken... No hope now :(
Nope, all 195 cards,
bought the last from an inn keeper in Skellige.
Xbox One, latest patch installed - quest doesn't 'complete'.

Shame, but I did it, so I'll live.