x

You have decided to merge your account with the GOG.com.

You can now start participating in the community discussions.

x

You chose to opt out from the merge process.
Please note that you will not be able to access your account until you opt in.

We strongly encourage you to merge your RED account with the GOG.com one.
If you want to do it later please try logging in again.

  • Register

Announcement

Collapse
No announcement yet.

PC holding down q to cast axii puppet does not work in combat.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts
This discussion is older than 365 days. Information contained in it may no longer be current. Please do not post new messages without substantial need.

  • PC holding down q to cast axii puppet does not work in combat.

    When out of combat holding down q will cast the puppet axii upgrade, but in combat no matter how long i hold it down it instantly casts the tier 1 axii spell that stuns. Please help!

  • #2
    Have you got the upgrade equipped? It works for me.

    Comment


    • #3
      Yeah I do. It is so frustrating I don't understand i have a corsair k70 cherry mx red if that's relevant. Like if i'm not fighting anything it will cast when i hold it down most of the time, but it never casts in combat, it just goes for the stun no matter what.

      Comment


      • #4
        I have an almost identical issue. PC (Steam) Version, I cannot cast puppet in combat or out. When I have both delusion and puppet equipped, it won't cast. I can cast puppet if I do not have delusion equipped. I can also only cast puppet when delusion is a maximum of level 1. Once delusion is equipped and giving the bonus of faster axii cast speed, puppet refuses to work in-combat or out.

        Comment


        • #5
          Yup you're experiencing the same thing as me. I'm on the steam version as well. Frustrating.

          Comment


          • #6
            I have managed to solve this for myself on the PC. It now works! I can have puppet and delusion at the same time.

            To fix this:

            Navigate to your folder: C:\Users\<User Name>\Documents\The Witcher 3

            Open the file "input.settings"

            Find all the entries for "IK_Q=(Action=CastSignHold,State=Duration,IdleTime=0.2)"

            Change the entry to have an IdleTime of 0.01. So after your change it should look like this:

            "IK_Q=(Action=CastSignHold,State=Duration,IdleTime=0.01)"

            There are multiple entries of this setting, so you will have to change them all.

            I didn't test it with other signs as this is a universal change to all alternate sign modes. But I am just happy to be able to use puppet and delusion at the same time now. It was driving me crazy to have to choose between them.

            Comment


            • #7
              Thank you! This worked for me.

              Comment


              • #8
                Same problem here. I noticed it does NOT affect casting with a controller, and also noticed that setting frame limit to 30 FPS fixed the problem.

                Gonna try the edit posted above as a workaround until it's properly fixed.

                Comment


                • #9
                  Torcrar, THANK YOU!

                  Comment


                  • #10
                    i have the same keyboard(nice choice btw) and the exact same issue only i've remapped it to cast using my mouse so i dont thinks its your KB. which is especially annoying since i've just used a few "greater Axii upgrades" on my armour for this purpose. im on the GOG version.

                    Comment


                    • #11
                      Can't even do this on the controller

                      Comment


                      • #12
                        just to clarify...this fix enables us to have both puppet and delusion usable by having both slotted? We still have to hold down the key to cast the alternate mode right?

                        Comment


                        • #13
                          Does anyone know if this will be fixed in the next patch? I have the game alt+tabbed right now and came here becasue of this bug. I am glad there is a fix here, but it still doesn't work with controller according to other posts. I have alternate igni and it works fine, but I do not have the base armor melt spell or whatever.

                          Comment


                          • #14
                            The bug is STILL present in the 1.05,the fix reported it works and give no problem with the other alternate signs..please fix..oh my god,how mutch it's bugged this game..the next time i hear about that only Bethesda make a bugged game...:rambo:

                            Comment


                            • #15
                              I've been having this issue quite a bit as well. It seems running the game at 60fps is the issue. If I lock myself at 30 I never have any problems. Hope there's a fix sometime.

                              The IdleTime=0.2 -> IdleTime=0.1 trick works well, just make sure you change your input settings to read only afterwards.
                              Last edited by captain_crunch; 25-06-15, 21:39.

                              Comment

                              Working...
                              X