Jobs Store Support Register

Cannot Use my Mouse Properly Because the Game Shows the Xbox Keybinding

+
Fixed the problem by restarting the game 4 times. For some reason the 4th time everything went back to normal o_O
The issue lies elsewhere, though. The problem is likely due to a third party driver interfering with Gwent. If, after unplugging all (Xbox) controllers, the problem still persists, please try the workarounds below:

I found short term solution but it's not a good solution for people who use gamepad in other games. Gwent uses xinput and loading it always when games starts, to resolve our problem just go to C:\Windows\System32 and found xinput1_3.dll and rename it, xinput1_3-old.dll is ok. Now when you start the game it will be unable for exe to load settings for gamepad and game will run in forced mouse and keyboard mode. For me everything works flawless now. If someone of you use gamepad in other games then you need to rename it again to xinput1_3.dll when you finish playing in gwent.
I found a solution for this issue.. The conflict is caused by a software called "vJoy".. I don't know why I had it installed but just uninstall it and PROBLEM SOLVED! (If you don't have that "vJoy" installed try to uninstall any third party program for the controls)

Another way:

- Right Click on My Computer and select 'Manage'
- Select 'Device Manager' from the pane on the left
- Expand 'Human Interface Devices'
- Right click on 'HID-compiant game controller' and select 'Disable'
- Done!
Also, perusing this thread might also give you some other suggestions.
 
I tried to play the game, but i couldn't get passed the tutorial. It kept not recognizing when I used my mouse or something. I can use my mouse to place cards on the field, I can right-click to cancel redrawing, but nothing else. I can't pick cards to redraw (have to use arrow keys and enter) and I can't skip my turn either. At all. When the game forced me to end my turn as part of the tutorial it let me do that no problem, but then we played the "real match" part of the tutorial, i laid out my cards, and i couldn't click the coin to finish, i clicked but nothing happened and i didn't know what keyboard button would do it for me, space and enter did nothing, so i had to end up just closing the game. does anyone know what is going on?
 
Just returned to gwent after a year of absence and have the issue with the controller too. I have a joystick and a xbox-controller connected and they both interfere with the keyboard-controls. As I also play other games (hard to imagine maybe...), i'm not willing to disconnect both controllers everytime i want to play gwent.
I have no third-party software managing my controllers on my pc, and they both work flawlessly in all other games. So the problem lies within gwent.

I'm rather staggered that the problem exists for nearly two years now an not one of the devs seems to care. It should be easy to fix: just raise the deadzone of the controller polling so that it just doesn't interfere anymore. Or add an option to disable controllers entirely in the game. Is this that hard to do? The automatic detection of the input method doesn't work in your game, and it's absolutely unnecessary to have it anyway.
 
Am returning to try Gwent again after many months of absence. Have installed Gwent client on my Windows 10 PC. Installation went OK. But when trying to play the game, I get a screen asking me to “consent to the new EULA”. It says it is necessary for me to play the new Gwent. There are three options: “I have read and accept the agreement”, “View User Agreement”, and “Exit”. I appears that the options are expecting a response from an XBOX controller because to accept the fore-mentioned options I must press (A), (RS), or (B) XBox Controller buttons, respectively. I cannot do this...I am on my PC! Cannot get out of this screen. Any help/ideas will be greatly appreciated. (I do have GWENT installed on my XBox One...seems to be working OK. But want it on my PC, to be played most of the time on my PC.)

Gwent EULA.jpg
 
I appears that the options are expecting a response from an XBOX controller because to accept the fore-mentioned options I must press (A), (RS), or (B) XBox Controller buttons, respectively. I cannot do this...I am on my PC!
Hmm... have you tried m&kb controls despite what the screen says? Could be it's just a visual error.
 
@Renkcer thread merged

The problem is likely due to a third party driver interfering with Gwent. If, after unplugging all (Xbox) controllers, the problem still persists, please try the workarounds below:

I found short term solution but it's not a good solution for people who use gamepad in other games. Gwent uses xinput and loading it always when games starts, to resolve our problem just go to C:\Windows\System32 and found xinput1_3.dll and rename it, xinput1_3-old.dll is ok. Now when you start the game it will be unable for exe to load settings for gamepad and game will run in forced mouse and keyboard mode. For me everything works flawless now. If someone of you use gamepad in other games then you need to rename it again to xinput1_3.dll when you finish playing in gwent.
I found a solution for this issue.. The conflict is caused by a software called "vJoy".. I don't know why I had it installed but just uninstall it and PROBLEM SOLVED! (If you don't have that "vJoy" installed try to uninstall any third party program for the controls)

Another way:

- Right Click on My Computer and select 'Manage'
- Select 'Device Manager' from the pane on the left
- Expand 'Human Interface Devices'
- Right click on 'HID-compiant game controller' and select 'Disable'
- Done!
Also, perusing this thread might also give you some other suggestions.
 
Same problem here, thinks my PC is an xbox. What a slap in the face of the platform that made CD Projekt who they are.

Game uninstalled. Too many good options out there to waste time monkeying around trying to get this one to work.
 
I've been playing Gwent on PC using Xbox 360 Controller without an issue till today, and the latest Network Update to Gwent. In-game some of the button commands do not register from my controller. Can you look into fixing this, thanks much.
 
Last edited by a moderator:
When starting Gwent it incorrectly detects that I am playing on gamepad, even when it's off. May very well be confusing it with my HOTAS setup, but I won't be un-rigging my flight sim hookup to play a casual card game, especially since no other game/program in universe has the same issue. Can you guys fix it, or at least provide us with some insane thing like, I don't know, configurable input source so we can toggle between gamepad and kb+mouse?

Seems like this is an issue going since 2016 and... still not reslved, but here's hoping that for a change someone will have a solution. Or not.